Opened 12 years ago

Closed 8 years ago

Last modified 8 years ago

#681 closed enhancement (obsolete)

Notifications need motion enhancement to indicate their relationship to the Frame.

Reported by: gdesmott Owned by: eben
Priority: Normal Milestone:
Component: Sugar Version: Unspecified
Severity: Major Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

On an up to date sugar-jhbuild, the FT icon blinks for a few second and then disappears from the frame making impossible to accept/decline the transfer.
I have this problem on both side.

Change History (6)

comment:1 Changed 12 years ago by tomeu

  • Owner changed from tomeu to eben
  • Status changed from new to assigned

the user thought that the notification icon was the only mean to interact with the file transfer operation. Moving to Eben in case he wants to point out any missing point in the current implementation (please retitle the ticket if needed).

comment:2 Changed 12 years ago by eben

  • Summary changed from file transfer icon blinks for a few seconds and then disappears to Notifications need motion enhancement to indicate their relationship to the Frame.

Of course. Notifications representing new objects (new file transfer, new clipping, buddy joined activity, network connected, etc.) are meant fade in, blink, and then slide off screen and "into" the Frame.

Notifications for objects already in the Frame (activity wants attention, Journal getting full, battery low, file transfer failed, etc.) are meant to slide out, then blink, and then slide back in.

Notifications which represent the removal of an object from the Frame (network connection lost, buddy left activity, etc.) are meant to slide out of the Frame, blink, and then fade out.

The big missing component is the sliding feature which illustrates that the notification doesn't simply disappear, but actually moves off the edge of the screen and into the Frame, where it can be accessed later.

comment:3 Changed 12 years ago by tomeu

  • Milestone changed from Unspecified by Release Team to 0.88
  • Priority changed from Unspecified by Maintainer to Normal
  • Severity changed from Unspecified to Minor
  • Type changed from defect to enhancement

comment:4 Changed 11 years ago by garycmartin

  • Milestone changed from 0.88 to 0.90
  • Severity changed from Minor to Major

Pushing to 0.90, but the need for improving/extending the notification UI does seems to be getting more critical...

comment:5 Changed 8 years ago by dnarvaez

  • Resolution set to obsolete
  • Status changed from assigned to closed

Old, very generic bug. If there are pieces of this which are important to implement these days please open separate bugs for them.

comment:6 Changed 8 years ago by dnarvaez

  • Milestone 0.90 deleted

Milestone 0.90 deleted

Note: See TracTickets for help on using tickets.