Opened 12 years ago

Closed 8 years ago

Last modified 8 years ago

#619 closed defect (obsolete)

Method "AddMembers" with signature "aus" on interface "org.freedesktop.Telepathy.Channel.Interface.Group" doesn't exist

Reported by: sascha_silbe Owned by: tomeu
Priority: Unspecified by Maintainer Milestone:
Component: sugar-presence-service Version: Git as of bugdate
Severity: Minor Keywords:
Cc: gdesmott Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

After changing Jabber servers, the following traceback occured. Can't reproduce, though.

1237835476.378396 DEBUG s-p-s.server_plugin: bbd694516715c4ebd882c99cb81b74541b5d477e@… (5) is not channel specific
1237835476.385502 DEBUG s-p-s.telepathy_plugin: <ServerPlugin object at 0x7f55b126b1e0 (telepathy_plugin+TelepathyPlugin at 0x142ab40)>: Contacts now
online:
1237835476.385926 DEBUG s-p-s.telepathy_plugin: 5 .../keyid/bbd694516715c4ebd882c99cb81b74541b5d477e
1237835476.386269 DEBUG s-p-s.presenceservice: Handle 5, .../keyid/bbd694516715c4ebd882c99cb81b74541b5d477e is now online
1237835476.386549 DEBUG s-p-s.presenceservice: Creating new buddy at .../keyid/bbd694516715c4ebd882c99cb81b74541b5d477e
1237835476.449482 ERROR dbus.connection: Exception in handler for D-Bus signal:
Traceback (most recent call last):

File "/var/lib/python-support/python2.5/dbus/connection.py", line 214, in maybe_handle_message

self._handler(*args, kwargs)

File "/home/sugar/sugar-jhbuild/install/share/sugar-presence-service/telepathy_plugin.py", line 514, in _new_channel_cb

self._publish_channel_cb(channel)

File "/home/sugar/sugar-jhbuild/install/share/sugar-presence-service/server_plugin.py", line 342, in _publish_channel_cb

self._add_not_subscribed_to_subscribe_channel()

File "/home/sugar/sugar-jhbuild/install/share/sugar-presence-service/server_plugin.py", line 363, in _add_not_subscribed_to_subscribe_channel

not_subscribed, )

File "/var/lib/python-support/python2.5/dbus/proxies.py", line 140, in call

keywords)

File "/var/lib/python-support/python2.5/dbus/connection.py", line 622, in call_blocking

message, timeout)

DBusException: org.freedesktop.DBus.Error.UnknownMethod: Method "AddMembers" with signature "aus" on interface
"org.freedesktop.Telepathy.Channel.Interface.Group" doesn't exist

Change History (6)

comment:1 Changed 12 years ago by gdesmott

I guess either Gabble crashed or the subscribe channel has been closed (because of disconnection probably).

A possible fix could be to set self._{subscribe,publish}_channel to None when connection is disconnected or when these channels are closed.
Then _add_not_subscribed_to_subscribe_channel should make an async call to GetAllMembers and the callback should check that self._subscribe_channel is still not None before calling AddMembers.

comment:2 Changed 12 years ago by tomeu

  • Owner changed from morgs to tomeu
  • Status changed from new to assigned

comment:3 Changed 11 years ago by sascha_silbe

  • Cc gdesmott added
  • Milestone changed from 0.86 to 0.88

I see these messages rather often (not just after reconnect).
gdesmott, can you prepare a patch, please? Debug messages stating that a channel got closed (if not already done) and that the callback was ignored because the channel was already closed would be useful.

comment:4 Changed 11 years ago by walter

  • Milestone changed from 0.88 to 0.90

presumably won't be landing in 0.88

comment:5 Changed 8 years ago by dnarvaez

  • Resolution set to obsolete
  • Status changed from assigned to closed

comment:6 Changed 8 years ago by dnarvaez

  • Milestone 0.90 deleted

Milestone 0.90 deleted

Note: See TracTickets for help on using tickets.