Opened 12 years ago

Closed 11 years ago

#612 closed defect (fixed)

Enable collapsible tables on the wiki

Reported by: FGrose Owned by: bernie
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: wiki.sugarlabs.org Version: Unspecified
Severity: Minor Keywords:
Cc: dfarning Distribution/OS: Unspecified
Bug Status: Resolved

Description

http://wiki.sugarlabs.org/go/MediaWiki:Common.js seems to exist, but the wiki markup {| class="collapsible prettytable" (Help:Collapsing) is not active.

This is needed to allow long sections or tables to be collapsed without loosing the local page context.

Wikipedia:NavFrame, is another section collapsing alternative.

Change History (5)

comment:1 Changed 12 years ago by FGrose

  • Bug Status changed from Unconfirmed to New
  • Component changed from infrastructure to wiki
  • Owner changed from krstic to dfarning
  • Type changed from enhancement to defect

comment:2 Changed 12 years ago by dfarning

  • Owner changed from dfarning to bernie
  • Status changed from new to assigned

Reassigning to Bernie.

comment:3 Changed 12 years ago by bernie

Hmmm I don't quite understand what needs to be done in order to enable this. It seems you have to paste a code snippet in your common.js. Quite kludgy, unless I'm mistaken.

Do we really need this?

comment:4 Changed 12 years ago by FGrose

  • Severity changed from Unspecified to Minor

Works for me in other wikis without any personal customization. I'm working on testwiki.laptop.org now and will investigate this feature further as I learn more about mediawiki configuration.

This a 'wanted' feature that can wait until we learn more about such things.

comment:5 Changed 11 years ago by FGrose

  • Bug Status changed from New to Resolved
  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed both Collapsible tables and divisions (NavFrame) by overwriting the relevant sections of http://wiki.sugarlabs.org/go/MediaWiki:Common.js with the corresponding code from MediaWiki and Wikipedia wikis.

Note: See TracTickets for help on using tickets.