Opened 12 years ago

Closed 11 years ago

Last modified 7 years ago

#611 closed defect (duplicate)

Resuming an ogg file from journal resumes Browse which just re-saves to journal again

Reported by: garycmartin Owned by: alsroot
Priority: Unspecified by Maintainer Milestone:
Component: Sugar Version: 0.86.x
Severity: Blocker Keywords:
Cc: erikos, kushal, tomeu Distribution/OS: Unspecified
Bug Status: New

Description

While testing ogg video content for a new Activity (testing under jhbuild), I notice that an ogg movie is not easy to play with the current sugar set-up. After using copy-to-journal test-movie.ogg -m video/ogg to get the ogg file into the journal, clicking the entry tries to resume it with Browse; Browse then displays a download alert that re-saves the ogg file as a nastly hex number named .ogv file which, if clicked, will also launch Browse and just save out another .ogv file to Journal. Never actually playing the video.

Manually starting a new instance of Jukebox, and using its journal object picker to select the original ogg file plays the movie correctly and with clean simple controls.

Looks like the sugar mime defaults need to be updated to make sure that Jukebox is used for audio and video content as it's a lighter weight media player than using Browse.

Attachments (3)

sugar-611.patch (4.3 KB) - added by alsroot 11 years ago.
sugar-611-browse.patch (1.0 KB) - added by alsroot 11 years ago.
sugar-611-jukebox.patch (1.4 KB) - added by alsroot 11 years ago.

Download all attachments as: .zip

Change History (20)

comment:1 Changed 12 years ago by erikos

  • Bug Status changed from Unconfirmed to New
  • Milestone changed from Unspecified by Release Team to 0.86

Let's make Jukebox the default player and test it with media files.

I will leave this open for 0.86 for further Browse improvements in this regard.

comment:2 Changed 12 years ago by tomeu

  • Severity changed from Unspecified to Blocker

comment:3 Changed 11 years ago by garycmartin

  • Cc erikos added

Yes, just to confirm this is still an issue. Did some (not so successful) testing at SugarCamp with Simon on this regarding Browse upload/download in an attempt to upload/download and resume various Journal entry types to/from the wiki.

comment:4 follow-up: Changed 11 years ago by alsroot

Should we close this ticket? For now, we have:

  • Jukebox is player by default for ogg files
  • if there is no Jukebox in system and Browse saves .ogg instead of playing, thats because of there is lack of proper xulrunner plugins(thus non-sugar issue)

comment:5 in reply to: ↑ 4 ; follow-up: Changed 11 years ago by alsroot

Replying to alsroot:

Should we close this ticket? For now, we have:

  • Jukebox is player by default for ogg files

hmm.. it doesn't work in all cases, in ubuntu ppa, default player is Browse

comment:6 in reply to: ↑ 5 Changed 11 years ago by garycmartin

Replying to alsroot:

Replying to alsroot:

Should we close this ticket? For now, we have:

  • Jukebox is player by default for ogg files

hmm.. it doesn't work in all cases, in ubuntu ppa, default player is Browse

Yea, I don't think Jukebox is registering all the MIME types it should be (audio.ogg would seem a really common one). I'm sure there is a ticket open, but I've seen no Jukebox release activity for the current sucrose cycle (~4 months) :-(

comment:7 Changed 11 years ago by alsroot

  • Keywords r? added

I guess, we'll have the same issue for honey mime_types. So, we can fix this issue by implementing feature requested by James Simmons some time ago on devel@ - use, by default, last "Resume with" chosen activity.

Changed 11 years ago by alsroot

comment:8 Changed 11 years ago by tomeu

  • Keywords r! added; r? removed

I think such a big change is better for 0.88. For 0.86 we can just remove the mime type from .info if really needed, or just let Jukebox be the default handler.

Though I think that the right fix is for Browse to not advertise what cannot handle itself.

comment:9 Changed 11 years ago by alsroot

patch was moved to #1493

Changed 11 years ago by alsroot

Changed 11 years ago by alsroot

comment:10 Changed 11 years ago by alsroot

  • Cc kushal added
  • Keywords r? added; r! removed
  • Version changed from Git as of bugdate to 0.86.x

last two patches are just moving mime types from Browse to Jukebox

comment:11 Changed 11 years ago by tomeu

ping kushal and erikos

comment:12 Changed 11 years ago by kushal

This should work, don't know why every time browse comes and claims all ogg files.

comment:13 Changed 11 years ago by alsroot

Since #1493 was commited, this issue is not critical(user can set Jukebox as default activity for ogv files), but using(last two patches)Jukebox(instead of Browse) as a default activity for media files could be still useful.

comment:14 Changed 11 years ago by tomeu

  • Cc tomeu added
  • Keywords r? removed
  • Owner changed from tomeu to alsroot
  • Status changed from new to assigned

comment:15 Changed 11 years ago by alsroot

  • Resolution set to duplicate
  • Status changed from assigned to closed

I've created #1809 and closing this one since it is a special case of #1809.

comment:16 Changed 11 years ago by alsroot

#1809 was postponed to 0.90 since we can reuse mime.defaults, so this ticket is a dup of #423.

comment:17 Changed 7 years ago by dnarvaez

  • Milestone 0.86 deleted

Milestone 0.86 deleted

Note: See TracTickets for help on using tickets.