Opened 12 years ago

Closed 8 years ago

Last modified 8 years ago

#588 closed task (wontfix)

Home list view: remove date column, enable alphabetical sort, label versions "Version x"

Reported by: FGrose Owned by: tomeu
Priority: Unspecified by Maintainer Milestone:
Component: Sugar Version: Unspecified
Severity: Unspecified Keywords:
Cc: eben, tomeu, marcopg, sascha_silbe Distribution/OS: Unspecified
Bug Status: New

Description

Observed in Soas1-20090319.

In list view I see a favorite star, activity icon, activity name, version number, and a date--but no explanation for number or date.

I was most perplexed by the number which I figured out was the version by from seeing those in the mailings. This may be mysterious for others wondering are there x versions or x instances or x what?

Perhaps, suffix the version # to the activity name (with some extra space, which doesn't show in the Trac wiki, so I've added some periods as place holders, which might work as well to separate and bind) instead of giving it its own column (which implied a count, to me). So it would be bound more closely with the name and not be in a separate column, like:

Story Builder . . . 13
Chat . . . 64
Terminal . . . 23
.
.
.

I take it that the date is the date of the image build and not of the activity version since they are all nearly the same. This doesn't really offer much useful information. Activity version date would be, perhaps, a useful reference.

Thanks for considering!

Change History (7)

comment:1 Changed 12 years ago by eben

  • Cc tomeu marcopg added

Yes, our initial designs contained a column view sort bar (such as can be seen in the Journal mockups here: http://wiki.sugarlabs.org/go/DesignTeam/Designs/Journal#03), but this control doesn't exist. The columns, of course, would indicate the meaning of the fields, such as version and installation date.

The reason installation date is included (admittedly not useful for activities that are installed with the base, since they share the same date) is so that this view can be arranged temporally much like the Journal as additional activities are added over time.

Perhaps we should consider re-factoring the list views to use a standard GTK column view of some kind, with rows which contain hippo canvases, instead of using a canvas for the whole view. Tomeu? Marco?

comment:2 Changed 12 years ago by tomeu

  • Milestone set to 0.86

comment:3 Changed 12 years ago by FGrose

  • Bug Status changed from Unconfirmed to New
  • Summary changed from Version column in Home list view may confuse, Date not very useful to Home list view: remove date column, enable alphabetical sort, label versions "Version x"
  • Type changed from defect to task

Consensus from http://meeting.sugarlabs.org/sugar-meeting.log.20090419_0911.html was

[10:26:16] <cms> #3: Home list view: remove the date column and enable alphabetical sort. Label versions "Version x"

comment:4 Changed 12 years ago by FGrose

Consider avoiding the text, 'Version', for the following reasons:

  • minimize text
    • international
    • graphical over lexical presentation
    • simpler
    • higher content/ink ratio
    • more beautiful without redundant words
  • Binding version # to name makes a unique name for the Activity instance object
    • useful for handling multiple versions of object class
    • version# is a defining attribute of the object instance
    • version# is not something one would sort on outside of the name group

comment:5 Changed 12 years ago by sascha_silbe

  • Cc sascha_silbe added

comment:6 Changed 8 years ago by dnarvaez

  • Resolution set to wontfix
  • Status changed from new to closed

This is 4 years old and it doesn't feel like a priority. Patches welcome.

comment:7 Changed 8 years ago by dnarvaez

  • Milestone 0.86 deleted

Milestone 0.86 deleted

Note: See TracTickets for help on using tickets.