Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#536 closed defect (duplicate)

Python 2.6 incompatibility: installs files to local/*

Reported by: sascha_silbe Owned by: gdesmott
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: telepathy Version: Git as of bugdate
Severity: Blocker Keywords: python2.6
Cc: Distribution/OS: Unspecified
Bug Status: Needinfo

Description

If using Python 2.6 (e.g. Ubuntu jaunty), telepathy will use incorrect installation paths (see attached file list).

Attachments (1)

telepathy-python-2.6.lst (9.4 KB) - added by sascha_silbe 13 years ago.
List of incorrectly installed files

Download all attachments as: .zip

Change History (5)

Changed 13 years ago by sascha_silbe

List of incorrectly installed files

comment:1 Changed 13 years ago by gdesmott

How did you install telepathy-python?

The python-telepathy Jaunty package seems just fine:

$ dpkg -L python-telepathy
/.
/usr
/usr/share
/usr/share/doc
/usr/share/doc/python-telepathy
/usr/share/doc/python-telepathy/README
/usr/share/doc/python-telepathy/AUTHORS
/usr/share/doc/python-telepathy/copyright
/usr/share/doc/python-telepathy/examples
/usr/share/doc/python-telepathy/examples/account.py
/usr/share/doc/python-telepathy/examples/aliases.py
/usr/share/doc/python-telepathy/examples/avatar.py
/usr/share/doc/python-telepathy/examples/call-gtk.py
/usr/share/doc/python-telepathy/examples/call.py
/usr/share/doc/python-telepathy/examples/chatroom.py
/usr/share/doc/python-telepathy/examples/connections.py
/usr/share/doc/python-telepathy/examples/deny.py
/usr/share/doc/python-telepathy/examples/file-transfer.py
/usr/share/doc/python-telepathy/examples/generate-manager-file.py
/usr/share/doc/python-telepathy/examples/message.py
/usr/share/doc/python-telepathy/examples/README
/usr/share/doc/python-telepathy/examples/register.py
/usr/share/doc/python-telepathy/examples/roomlist.py
/usr/share/doc/python-telepathy/examples/roster.py
/usr/share/doc/python-telepathy/examples/stream_tube_client.py
/usr/share/doc/python-telepathy/examples/tube-dbus-muc.py
/usr/share/doc/python-telepathy/examples/tube-stream-muc.py
/usr/share/doc/python-telepathy/examples/tube-stream-private.py
/usr/share/doc/python-telepathy/examples/tubeconn.py
/usr/share/doc/python-telepathy/examples/watch.py
/usr/share/doc/python-telepathy/NEWS.gz
/usr/share/doc/python-telepathy/changelog.Debian.gz
/usr/share/pyshared
/usr/share/pyshared/telepathy
/usr/share/pyshared/telepathy/client
/usr/share/pyshared/telepathy/client/init.py
/usr/share/pyshared/telepathy/client/channel.py
/usr/share/pyshared/telepathy/client/conn.py
/usr/share/pyshared/telepathy/client/connmgr.py
/usr/share/pyshared/telepathy/client/interfacefactory.py
/usr/share/pyshared/telepathy/client/managerregistry.py
/usr/share/pyshared/telepathy/server
/usr/share/pyshared/telepathy/server/init.py
/usr/share/pyshared/telepathy/server/channel.py
/usr/share/pyshared/telepathy/server/channelhandler.py
/usr/share/pyshared/telepathy/server/conn.py
/usr/share/pyshared/telepathy/server/connmgr.py
/usr/share/pyshared/telepathy/server/handle.py
/usr/share/pyshared/telepathy/server/media.py
/usr/share/pyshared/telepathy/server/properties.py
/usr/share/pyshared/telepathy/_generated
/usr/share/pyshared/telepathy/_generated/interfaces.py
/usr/share/pyshared/telepathy/_generated/constants.py
/usr/share/pyshared/telepathy/_generated/errors.py
/usr/share/pyshared/telepathy/_generated/Account.py
/usr/share/pyshared/telepathy/_generated/Account_Interface_Avatar.py
/usr/share/pyshared/telepathy/_generated/Account_Manager.py
/usr/share/pyshared/telepathy/_generated/Channel.py
/usr/share/pyshared/telepathy/_generated/Channel_Handler.py
/usr/share/pyshared/telepathy/_generated/Channel_Interface_Call_State.py
/usr/share/pyshared/telepathy/_generated/Channel_Interface_Chat_State.py
/usr/share/pyshared/telepathy/_generated/Channel_Interface_DTMF.py
/usr/share/pyshared/telepathy/_generated/Channel_Interface_Destroyable.py
/usr/share/pyshared/telepathy/_generated/Channel_Interface_Group.py
/usr/share/pyshared/telepathy/_generated/Channel_Interface_Hold.py
/usr/share/pyshared/telepathy/_generated/Channel_Interface_Media_Signalling.py
/usr/share/pyshared/telepathy/_generated/Channel_Interface_Media_Signalling_Future.py
/usr/share/pyshared/telepathy/_generated/Channel_Interface_Messages.py
/usr/share/pyshared/telepathy/_generated/Channel_Interface_Password.py
/usr/share/pyshared/telepathy/_generated/Channel_Type_Contact_List.py
/usr/share/pyshared/telepathy/_generated/Channel_Type_File_Transfer.py
/usr/share/pyshared/telepathy/_generated/Channel_Type_Room_List.py
/usr/share/pyshared/telepathy/_generated/Channel_Type_Streamed_Media.py
/usr/share/pyshared/telepathy/_generated/Channel_Type_Streamed_Media_Future.py
/usr/share/pyshared/telepathy/_generated/Channel_Type_Text.py
/usr/share/pyshared/telepathy/_generated/Channel_Type_Tubes.py
/usr/share/pyshared/telepathy/_generated/Connection.py
/usr/share/pyshared/telepathy/_generated/Connection_Interface_Aliasing.py
/usr/share/pyshared/telepathy/_generated/Connection_Interface_Avatars.py
/usr/share/pyshared/telepathy/_generated/Connection_Interface_Capabilities.py
/usr/share/pyshared/telepathy/_generated/Connection_Interface_Contacts.py
/usr/share/pyshared/telepathy/_generated/Connection_Interface_Presence.py
/usr/share/pyshared/telepathy/_generated/Connection_Interface_Requests.py
/usr/share/pyshared/telepathy/_generated/Connection_Interface_Simple_Presence.py
/usr/share/pyshared/telepathy/_generated/Connection_Manager.py
/usr/share/pyshared/telepathy/_generated/Media_Session_Handler.py
/usr/share/pyshared/telepathy/_generated/Media_Stream_Handler.py
/usr/share/pyshared/telepathy/_generated/Properties_Interface.py
/usr/share/pyshared/telepathy/_generated/init.py
/usr/share/pyshared/telepathy/init.py
/usr/share/pyshared/telepathy/_version.py
/usr/share/pyshared/telepathy/constants.py
/usr/share/pyshared/telepathy/errors.py
/usr/share/pyshared/telepathy/interfaces.py
/usr/share/pyshared/telepathy/utils.py
/usr/share/pyshared/telepathy_python-0.15.7.egg-info
/usr/share/pyshared-data
/usr/share/pyshared-data/python-telepathy

comment:2 Changed 13 years ago by erikos

  • Bug Status changed from New to Needinfo

Sascha can you follow up? Is this a blocker for 0.84?

comment:3 Changed 13 years ago by sascha_silbe

  • Resolution set to duplicate
  • Status changed from new to closed

Oops, forgot one dupe of #538.
Was a Ubuntu-only bug and has been fixed by now. No need to worry about for 0.84.

comment:4 Changed 13 years ago by erikos

Awesome, thanks.

Note: See TracTickets for help on using tickets.