Opened 12 years ago

Closed 12 years ago

#505 closed task (fixed)

Jabber.sugarlabs.org 5222 port not responding

Reported by: garycmartin Owned by: bernie
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: infrastructure Version: Unspecified
Severity: Unspecified Keywords:
Cc: gdesmott, bernie, sascha_silbe Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Trying to test the new F11 builds with collaboration here having not seen any buddies in the neighbourhood for some time. FWIW, local AP collaboration via salut is failing (will report this elsewhere I think), but when testing it also turns out that jabber.sugarlabs.org is not responding:

telnet jabber.sugarlabs.org 5222

Managing to temporally use jabber.olpchacks.org to test for now.

Change History (17)

comment:1 Changed 12 years ago by tomeu

  • Cc gdesmott added

There was some issue related to ejabberd consuming more memory than it's supposed to.

comment:2 Changed 12 years ago by gdesmott

Yeah for some reason ejabberd decided than eating as much memory as possible was really fun... :(

comment:3 Changed 12 years ago by bernie

  • Cc bernie added

I think Cassidy is the admin of jabber.sugarlabs.org.

I'd like to get access to that VM if possible, or better consolidate it with the other ejabberd server running on sunjammer to provide service for USER@….

comment:4 follow-up: Changed 12 years ago by gdesmott

Apparantly ejabberd stopped to consume that much memory. Is that working for you?

Bernie: sure. Did you check if we can have LDAP and "local" accounts at the same time (as we discussed in Brussels)?

comment:5 in reply to: ↑ 4 ; follow-up: Changed 12 years ago by bernie

Replying to gdesmott:

Bernie: sure. Did you check if we can have LDAP and "local" accounts at the same time (as we discussed in Brussels)?

Yeah, it's supported:

{auth_method, [internal, ldap]}.

comment:6 in reply to: ↑ 5 Changed 12 years ago by bernie

Replying to bernie:

{auth_method, [internal, ldap]}.

The whole thing would be:

{auth_method, [internal, ldap]}.
{ldap_servers, ["ldap.sugarlabs.org"]}.
{ldap_base, "dc=sugarlabs,dc=org"}.
{ldap_uids, [{"uid", "%u"}]}.

comment:7 Changed 12 years ago by bernie

(slapd on sunjammer is currently only reachable from localhost)

comment:8 follow-up: Changed 12 years ago by gdesmott

Cool. Could you open another ticket to track the LDAP integration?

comment:9 Changed 12 years ago by FGrose

  • Component changed from sugar-presence-service to infrastructure

comment:10 in reply to: ↑ 8 Changed 12 years ago by bernie

Replying to gdesmott:

Cool. Could you open another ticket to track the LDAP integration?

Done. See #546 .

comment:11 Changed 12 years ago by garycmartin

FWIW, I think jabber.sugarlabs.org:5222 has been off-line again now since the end of last week. Is this still the flakey jabberd with shared roster issues?

comment:12 Changed 12 years ago by gdesmott

For some reason Ejabberd decided to occasionnally start to consume as much memory as possible. :\
The shared roster is not enabled so that's not the reason of this failure.

comment:13 Changed 12 years ago by sascha_silbe

  • Cc sascha_silbe added

comment:14 Changed 12 years ago by CarolineM

schoolserver.solutiongrove.com is currently working.

Solution Grove needs to stress test our system. Does it make sense to redirect jabber.sugarlabs.org to schoolserver.solutiongrove.com for a few weeks? I think we have more bandwidth to upgrade, gather statistics and debug. If there are people in the community who want to join us we can give them shell access to the VM we are running.

comment:15 Changed 12 years ago by bernie

I believe the Sugar Labs developers require Gadget to test integration.

Does the XS already support it? If not, could Solution Grove work on the integrating it?

Also, if we could get LDAP support working there, I'd turn off the other ejabberd instance on sunjammer and repoint the SRV records to the schoolserver.

comment:16 Changed 12 years ago by daveb

We can install Gadget, its not included in XS yet (at least I'll try to install it!)

What do we need LDAP for? I am not sure I understand what LDAP and SRV are for.

comment:17 Changed 12 years ago by garycmartin

  • Resolution set to fixed
  • Status changed from new to closed

Closing as this was a specific incident, maybe need a new ticket for "0.86 implement gadget and design it's Sugar UI"

Note: See TracTickets for help on using tickets.