Opened 3 months ago

Last modified 2 months ago

#4994 reopened defect

Fedora 29 SoaS liveinst fails

Reported by: quozl Owned by:
Priority: High Milestone: Unspecified
Component: Sugar on a Stick (SoaS) Version: Unspecified
Severity: Critical Keywords:
Cc: Distribution/OS: Fedora
Bug Status: New

Description

Cannot install Fedora 29 SoaS using liveinst method, as it dies with a signal 11. Reproduced on KVM and hardware.

Workaround is to install Fedora 29 and then install Sugar, per instructions at https://github.com/sugarlabs/sugar/blob/master/docs/fedora.md

[liveuser@localhost ~]$ sudo liveinst

We trust you have received the usual lecture from the local System
Administrator. It usually boils down to these three things:

    #1) Respect the privacy of others.
    #2) Think before you type.
    #3) With great power comes great responsibility.

Starting installer, one moment...
anaconda 29.24.7-1.fc29 for Fedora 29 started.
 * installation log files are stored in /tmp during the installation
 * shell is available on TTY2 and in second TMUX pane (ctrl+b, then press 2)
 * when reporting a bug add logs from /tmp as separate text/plain attachments
No protocol specified
No protocol specified
Anaconda received signal 11!.
/usr/lib64/python3.7/site-packages/pyanaconda/_isys.so(+0x1596)[0x7fd4032e9596]
/lib64/libpthread.so.0(+0x12f70)[0x7fd4114aff70]
/lib64/libgtk-3.so.0(+0x2f8eed)[0x7fd3f908aeed]
/lib64/libgtk-3.so.0(+0x190c38)[0x7fd3f8f22c38]
/lib64/libgtk-3.so.0(+0x1a6d68)[0x7fd3f8f38d68]
/lib64/libgtk-3.so.0(+0x192062)[0x7fd3f8f24062]
/lib64/libgtk-3.so.0(+0x1a6c90)[0x7fd3f8f38c90]
/lib64/libgtk-3.so.0(+0x1a6ced)[0x7fd3f8f38ced]
/lib64/libgtk-3.so.0(+0x192aa6)[0x7fd3f8f24aa6]
/lib64/libgobject-2.0.so.0(g_type_create_instance+0x2dd)[0x7fd403a631cd]
/lib64/libgobject-2.0.so.0(+0x168d8)[0x7fd403a458d8]
/lib64/libgobject-2.0.so.0(g_object_new_with_properties+0x275)[0x7fd403a47025]
/lib64/libgobject-2.0.so.0(g_object_new+0xc1)[0x7fd403a47be1]
/lib64/libgtk-3.so.0(+0x1af56e)[0x7fd3f8f4156e]
/lib64/libgtk-3.so.0(+0x38bf7a)[0x7fd3f911df7a]
/lib64/libgobject-2.0.so.0(g_type_create_instance+0x2dd)[0x7fd403a631cd]
/lib64/libgobject-2.0.so.0(+0x168d8)[0x7fd403a458d8]
/lib64/libgobject-2.0.so.0(g_object_newv+0x24d)[0x7fd403a4737d]
/usr/lib64/python3.7/site-packages/gi/_gi.cpython-37m-x86_64-linux-gnu.so(+0x2148c)[0x7fd403c0c48c]
/usr/lib64/python3.7/site-packages/gi/_gi.cpython-37m-x86_64-linux-gnu.so(+0x17fed)[0x7fd403c02fed]
[New LWP 1802]
[New LWP 1803]
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
0x00007fd4114af8f2 in waitpid () from /lib64/libpthread.so.0
Saved corefile /tmp/anaconda.core.1799
[Inferior 1 (process 1799) detached]
[liveuser@localhost ~]$ 

Attachments (1)

anaconda.log (6.5 KB) - added by FGrose 3 months ago.
anaconda.log from dd'ed .iso boot

Download all attachments as: .zip

Change History (6)

comment:1 Changed 3 months ago by FGrose

Works for me:

[liveuser@localhost-live ~]$ sudo liveinst
umount: /home: target is busy.
Starting installer, one moment...
anaconda 29.24.7-1.fc29 for Fedora 29 started.
 * installation log files are stored in /tmp during the installation
 * shell is available on TTY2 and in second TMUX pane (ctrl+b, then press 2)
 * when reporting a bug add logs from /tmp as separate text/plain attachments
Warning:          Unsupported high keycode 372 for name <I372> ignored
                  X11 cannot support keycodes above 255.
                  This warning only shows for the first high keycode.
[liveuser@localhost-live ~]$ 
[liveuser@localhost-live ~]$ ls -la /mnt/sysimage/
total 76
dr-xr-xr-x.  18 root root  4096 Oct 24 19:55 .
drwxr-xr-x.   3 root root  4096 Jan  2 00:25 ..
lrwxrwxrwx.   1 root root     7 Jul 13 00:48 bin -> usr/bin
dr-xr-xr-x.   6 root root  4096 Jan  2 00:36 boot
drwxr-xr-x.  22 root root  4440 Jan  2 00:43 dev
drwxr-xr-x. 112 root root 12288 Jan  2 00:44 etc
drwxr-xr-x.   3 root root  4096 Jan  2 00:44 home
lrwxrwxrwx.   1 root root     7 Jul 13 00:48 lib -> usr/lib
lrwxrwxrwx.   1 root root     9 Jul 13 00:48 lib64 -> usr/lib64
drwx------.   2 root root 16384 Oct 24 19:54 lost+found
drwxr-xr-x.   2 root root  4096 Jul 13 00:48 media
drwxr-xr-x.   2 root root  4096 Jul 13 00:48 mnt
drwxr-xr-x.   2 root root  4096 Jul 13 00:48 opt
dr-xr-xr-x. 244 root root     0 Jan  1 19:17 proc
dr-xr-x---.   2 root root  4096 Oct 24 20:00 root
drwxr-xr-x.  36 root root  1180 Jan  2 00:45 run
lrwxrwxrwx.   1 root root     8 Jul 13 00:48 sbin -> usr/sbin
drwxr-xr-x.   2 root root  4096 Jul 13 00:48 srv
dr-xr-xr-x.  13 root root     0 Jan  2 00:17 sys
drwxrwxrwt.   3 root root  4096 Jan  2 00:44 tmp
drwxr-xr-x.  12 root root  4096 Oct 24 19:55 usr
drwxr-xr-x.  21 root root  4096 Oct 24 19:59 var

comment:2 Changed 3 months ago by quozl

  • Resolution set to invalid
  • Status changed from new to closed

Thanks for testing. It happens with Fedora-SoaS-Live-x86_64-29-1.2.iso, and from your shell prompt you must be using a later ISO. I can't afford the data to get a later ISO at the moment, so I'll close the ticket.

Changed 3 months ago by FGrose

anaconda.log from dd'ed .iso boot

comment:3 Changed 3 months ago by FGrose

  • Resolution invalid deleted
  • Status changed from closed to reopened

I used that .iso to load a LiveUSB with livecd-iso-to-disk and then proceeded from the booted LiveUSB to run the liveinst that succeeded above.

However, if that .iso is dd'ed to the USB flash drive and then booted, that instance failed as you noted. I've attached the anaconda.log from /tmp.

Last edited 3 months ago by FGrose (previous) (diff)

comment:4 Changed 3 months ago by quozl

Thanks, interesting. I've never bothered with the extra time of livecd-iso-to-disk, as I expect to be able to run the installer from any Fedora Live ISO already. But that data point may help someone who knows Anaconda to diagnose a traceback. The workaround of using the Fedora Workstation Live ISO will be suitable for most people, and as a bonus provides all of Fedora Workstation.

Note: See TracTickets for help on using tickets.