Opened 2 years ago

Closed 2 years ago

#4981 closed defect (fixed)

Browse Show in Journal button fails

Reported by: FGrose Owned by:
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Browse Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: Fedora
Bug Status: Unconfirmed

Description

After downloading an Activity from activities.sugarlabs.org, the 'Show in Journal' button is offered in a message. Clicking it fails to open the Journal; the message is dismissed and the pointer continues as a busy spinner.

Observed in Fedora-SoaS-Live-x86_64-26-20170429.n.0.iso

Attachments (2)

log-1493674506.zip (31.9 KB) - added by FGrose 2 years ago.
Log capture
log-1496928206.zip (18.9 KB) - added by FGrose 2 years ago.
log capture

Download all attachments as: .zip

Change History (9)

Changed 2 years ago by FGrose

Log capture

comment:1 Changed 2 years ago by quozl

Does https://github.com/sugarlabs/browse-activity/commit/aadc1703fb5207e17bc75974d932d401d795d53c fix this? Your logs contained;

Traceback (most recent call last):
  File "/usr/share/sugar/activities/Browse.activity/browser.py", line 822, in __load_failed_cb
    if web_error.code == WebKit2.NetworkError.CANCLLED:
AttributeError: type object 'NetworkError' has no attribute 'CANCLLED'

but not sure if that also causes the symptom you report.

comment:2 Changed 2 years ago by FGrose

Not fixed...
The bundle is downloaded. Pressing 'Show in Journal' seems to have installed the Activity but not switched views to the Journal.

From WebActivity log:

1493823645.540347 ERROR root: __download_requested_cb 'http://activities.sugarlabs.org/activities/4708/cedit-3.xo'
1493823645.546217 ERROR root: gi.FunctionInfo(get_destination)
1493823645.586067 ERROR root: _create_journal_object
1493823645.802286 ERROR root: __download_finished_cb

From shell.log:

Archive:  /home/liveuser/.sugar/default/data/844c0a11-5a9c-40f9-b580-ba2388cd6c12_qelPCi.xo
   creating: /home/liveuser/Activities/CEdit.activity/
  inflating: /home/liveuser/Activities/CEdit.activity/CEdit.py  
   creating: /home/liveuser/Activities/CEdit.activity/activity/
  inflating: /home/liveuser/Activities/CEdit.activity/activity/activity.info  
  inflating: /home/liveuser/Activities/CEdit.activity/activity/icon.svg  
  inflating: /home/liveuser/Activities/CEdit.activity/globals.py  
1493823646.128751 ERROR root: No bundle in '/home/liveuser/Activities/CEdit.activity'
   creating: /home/liveuser/Activities/CEdit.activity/icons/
  inflating: /home/liveuser/Activities/CEdit.activity/icons/clock.svg  
  inflating: /home/liveuser/Activities/CEdit.activity/icons/compressed.svg  
  inflating: /home/liveuser/Activities/CEdit.activity/icons/executable.svg  
  inflating: /home/liveuser/Activities/CEdit.activity/icons/folder-desktop.svg  
  inflating: /home/liveuser/Activities/CEdit.activity/icons/folder-documents.svg  
  inflating: /home/liveuser/Activities/CEdit.activity/icons/folder-download.svg  
  inflating: /home/liveuser/Activities/CEdit.activity/icons/folder-home.svg  
  inflating: /home/liveuser/Activities/CEdit.activity/icons/folder-music.svg  
  inflating: /home/liveuser/Activities/CEdit.activity/icons/folder-pictures.svg  
  inflating: /home/liveuser/Activities/CEdit.activity/icons/folder-video.svg  
  inflating: /home/liveuser/Activities/CEdit.activity/icons/folder.svg  
  inflating: /home/liveuser/Activities/CEdit.activity/icons/font-text.svg  
  inflating: /home/liveuser/Activities/CEdit.activity/icons/html.svg  
  inflating: /home/liveuser/Activities/CEdit.activity/icons/inode-symlink.svg  
  inflating: /home/liveuser/Activities/CEdit.activity/icons/new-file.svg  
  inflating: /home/liveuser/Activities/CEdit.activity/icons/new-folder.svg  
  inflating: /home/liveuser/Activities/CEdit.activity/icons/pdf.svg  
  inflating: /home/liveuser/Activities/CEdit.activity/icons/pendrive.svg  
  inflating: /home/liveuser/Activities/CEdit.activity/icons/picture.svg  
  inflating: /home/liveuser/Activities/CEdit.activity/icons/plain.svg  
  inflating: /home/liveuser/Activities/CEdit.activity/icons/python.svg  
  inflating: /home/liveuser/Activities/CEdit.activity/icons/resize+.svg  
  inflating: /home/liveuser/Activities/CEdit.activity/icons/resize-.svg  
  inflating: /home/liveuser/Activities/CEdit.activity/icons/save-as.svg  
  inflating: /home/liveuser/Activities/CEdit.activity/icons/show-hidden-files.svg  
  inflating: /home/liveuser/Activities/CEdit.activity/icons/show-numbers.svg  
  inflating: /home/liveuser/Activities/CEdit.activity/icons/show-right-line.svg  
  inflating: /home/liveuser/Activities/CEdit.activity/icons/sound.svg  
  inflating: /home/liveuser/Activities/CEdit.activity/icons/unknown.svg  
  inflating: /home/liveuser/Activities/CEdit.activity/icons/video.svg  
  inflating: /home/liveuser/Activities/CEdit.activity/icons/wrap-none.svg  
  inflating: /home/liveuser/Activities/CEdit.activity/setup.py  
  inflating: /home/liveuser/Activities/CEdit.activity/widgets.py  
caution: excluded filename not matched:  mimetype
1493823657.566047 WARNING root: No activity can start object with type, application/vnd.olpc-sugar.

Changed 2 years ago by FGrose

log capture

comment:4 Changed 2 years ago by FGrose

Another problem?
Download counted down but then there was no followon notice.
The Browse tab continues to show 'Loading...' message/title.
Journal shows this item:

Downloading None from 
http://activities.sugarlabs.org/activities/4708/cedit-3.xo.

WebActivity log:

/usr/lib/python2.7/site-packages/sugar3/activity/activity.py:96: PyGIWarning: SugarExt was imported without specifying a version first. Use gi.require_version('SugarExt', '1.0') before import to ensure that the right version gets loaded.
  from gi.repository import SugarExt
Traceback (most recent call last):
  File "/home/liveuser/Activities/Browse.activity/browser.py", line 828, in __decide_policy_cb
    self._activity.unbusy()
AttributeError: 'WebActivity' object has no attribute 'unbusy'
1496927966.447948 ERROR root: gi.FunctionInfo(get_destination)
Traceback (most recent call last):
  File "/home/liveuser/Activities/Browse.activity/downloadmanager.py", line 209, in __download_finished_cb
    self._activity.unbusy()
AttributeError: 'WebActivity' object has no attribute 'unbusy'

Closing tab has no effect.
Stopping Browse shows this warning:

Download in progress
Stopping now will erase your download (x) Continue download (✓) Stop

Observed on SoaS 26 alpha (dnf upgraded to 2017-Jun-07)

Last edited 2 years ago by FGrose (previous) (diff)

comment:5 Changed 2 years ago by quozl

Fixed in
https://github.com/sugarlabs/browse-activity/commit/99adc3af893e24467ae0da30689008c6daa6bdb8

Please test
http://people.sugarlabs.org/~quozl/Browse-201.2.xo

Was caused by my testing against current sugar-toolkit-gtk3 instead of the older version in SoaS.

comment:6 Changed 2 years ago by FGrose

Fix confirmed. Works as expected in SoaS 26 alpha dnf upgraded. Thanks!

comment:7 Changed 2 years ago by quozl

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.