Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#4912 closed defect (fixed)

background control panel alpha level may set wrongly

Reported by: quozl Owned by:
Priority: Low Milestone: Unspecified
Component: Sugar Version: Git as of bugdate
Severity: Minor Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: New

Description

Reproducer: instrument the model.py to log changes to alpha level, then use the alpha level buttons on the background control panel.

The calls to the model are inconsistent with user actions.

Sometimes the saved alpha level is not what the user intended.

  • the _set_alpha_cb in the view is called twice for every click, once for the radio button which was active, and once for the radio button which is now active; widget.get_active() could be used to filter the calls to ignore the deactivated button.
  • the _set_alpha_cb in the view is called when the alpha level buttons are being created; connect() could be called after all the buttons are created instead of after each button is created.

Change History (2)

comment:1 Changed 5 years ago by tch

  • Resolution set to fixed
  • Status changed from new to closed

comment:2 Changed 5 years ago by quozl

Is in 0.107.1

Note: See TracTickets for help on using tickets.