Opened 7 years ago

Closed 7 years ago

#4907 closed defect (fixed)

File transfer shows empathy popup

Reported by: SAMdroid Owned by:
Priority: High Milestone: Unspecified
Component: Sugar Version: Git as of bugdate
Severity: Major Keywords:
Cc: Distribution/OS: Fedora
Bug Status: Unconfirmed

Description

When sending a file to a buddy in sugar causes an empathy popup. Tested on fc24 rawhide from osbuild mode none.

Steps to reproduce:

  1. Have 2 instances
  2. Send a file from A to B
  3. See the filechooser popup in B's sugar
  4. Note that the file transfer can still be completed normally (sugar way) in B's sugar if you close the filechooser
  5. Note that the filechooser is from empathy according to gtk inspector

Also, pkilling empathy does not seem to stop the issue :(

From my bad understanding of telepathy empathy might be started by mission control [1]. We implement a channel handler, but I don't think that we have a dbus service that mission control activates, so maybe that is what is happening?

Or maybe we aren't accepting the channel correctly?

[1] http://telepathy.freedesktop.org/doc/book/chapter.channel-dispatcher.html

Change History (6)

comment:1 Changed 7 years ago by SAMdroid

Hum, setting the prefered handler seems to help. It seems to pop up with the sugar notification first if sugar is the prefered handler, but the filechooser still shows.

I think that we need a channel approver [1]. It offers an interface to say who should handle each channel [2]. It also says in the teleapthy book:

It is very rare that you will need to implement an Approver, in general the Approver will be provided by your desktop environment.

[1] http://telepathy.freedesktop.org/doc/book/sect.channel-dispatcher.clients.html#sect.channel-dispatcher.clients.impl.approver
[2] http://telepathy.freedesktop.org/spec/Channel_Dispatch_Operation.html

comment:2 Changed 7 years ago by quozl

agreed. 12898 (empathy-chat may appear, ubuntu) may also be of interest; same underlying problem, perhaps.

comment:4 Changed 7 years ago by SAMdroid

Almost everything I said before was wrong:

  • Sugar already has an approver - it is used for activity invites
  • the sugar approver also passes unsolicited chats to org.laptop.Chat activity, so olpc:12898 should already be accounted for
  • The sugar approver didn't deal with file transfer tubes, so it went to empathy because it seemed to be indicated as the first preference client. Or maybe that was just alphabetical ordering :)

comment:5 Changed 7 years ago by quozl

On my Fedora 18 builds, with Sugar 0.107.0, empathy is not present. Adding it does not reproduce your problem.

On my Ubuntu 14.04.3 builds, with Sugar 0.107.0, empathy is present, and your problem does reproduce. Applying your pr611 does fix.

comment:6 Changed 7 years ago by quozl

  • Resolution set to fixed
  • Status changed from new to closed

Is in 0.107.1

Note: See TracTickets for help on using tickets.