Opened 7 years ago

Closed 7 years ago

#4902 closed defect (wontfix)

Separator height has regressed

Reported by: ignacio Owned by:
Priority: Low Milestone: Unspecified
Component: Sugar Version: Git as of bugdate
Severity: Minor Keywords:
Cc: Distribution/OS: Fedora
Bug Status: New

Description

Fedora 24 (rawhide), Gtk 3.18

The separators on toolbars (and I think in submenus too) have regressed.

They height is 100% of the main widget.

How to see it:
1) Open read activity
2) Click on viewtoolbar
3) See the separators.

Attachments (2)

7d50c0dc6aa7ddbd4fbbc31a10c41f43.png (14.0 KB) - added by SAMdroid 7 years ago.
Screenshot of _Read Activity_.png (15.3 KB) - added by ignacio 7 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 7 years ago by ignacio

A small patch can be:

diff --git a/gtk3/theme/gtk-widgets.css.em b/gtk3/theme/gtk-widgets.css.em
index 9b636c8..35d0a1d 100644
--- a/gtk3/theme/gtk-widgets.css.em
+++ b/gtk3/theme/gtk-widgets.css.em
@@ -73,7 +73,7 @@ disabled_opacity = 0.5
     /* 0.05 works good for both the sugar and sugar-xo themes */
     -GtkWidget-cursor-aspect-ratio: 0.05;
 
-    -GtkWidget-wide-separators: true;
+    -GtkWidget-wide-separators: false;
     -GtkWidget-separator-height: $thickness;
     -GtkWidget-separator-width: $thickness;
 
@@ -551,6 +551,7 @@ SugarPaletteWindowWidget GtkProgressBar.trough {
 /* Separators */
 
 .separator {
+    color: @button_grey;
     border-style: solid;
     border-color: @button_grey;
     border-width: $(thickness)px;


But the problem is that the width will not be the same as usually.
When you test the patch in XO, with older Gtk version, the separators are too small.

comment:2 Changed 7 years ago by SAMdroid

Can not reproduce on fedora 24 rawhide with gtk 3.18.1.

Changed 7 years ago by SAMdroid

comment:3 Changed 7 years ago by ignacio

Yep, you did.

Here is how it should look (screenshot from XO)

Last edited 7 years ago by ignacio (previous) (diff)

Changed 7 years ago by ignacio

comment:5 Changed 7 years ago by SAMdroid

  • Resolution set to wontfix
  • Status changed from new to closed

I think the idea was that I liked the new look and that it was hard to correctly fix.

Marking as WONTFIX.

Note: See TracTickets for help on using tickets.