Opened 6 years ago

Closed 6 years ago

#4866 closed defect (fixed)

Hotkeys stop working on Sugar

Reported by: godiard Owned by:
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

This sequence makes hotkeys stop working:

  • Open a activity.
  • Open Help window.
  • Close the activity clicking the close button, but without close the help window.
  • The help window is closed, and the activity too, but the funtion keys do not reply anymore.

In shell.log we see:
1435235189.488383 DEBUG root: _key_pressed_cb: 72 0 F6
1435235189.488509 DEBUG root: Key F6 action stopped due to modal dialog open

This mean the shell think the Help window is still open.

The same issue do not happen with the View Source window, even when the code is almost the same.

Change History (2)

comment:2 Changed 6 years ago by Gonzalo Odiard

  • Resolution set to fixed
  • Status changed from new to closed

Help window: notify window closed o the shell on hide - Fixes #4866

Instead of notify the window was closed in the stop button click event
do it when the window is hidden, because the window can be closed
when the activity associated is closed, and in that case the shell
was confused. More information in the ticket.

Changeset: 105897dc2f1fc61e16066b7e59c0307274ebda9e

Note: See TracTickets for help on using tickets.