Opened 6 years ago

Closed 6 years ago

#4861 closed defect (fixed)

Brightness does not work during first startup

Reported by: quozl Owned by:
Priority: Normal Milestone: Unspecified
Component: Sugar Version: Git as of bugdate
Severity: Major Keywords:
Cc: martin.abente.lahaye@… Distribution/OS: Ubuntu
Bug Status: New

Description

While choosing colour, gender, and age, the brightness keys do not work. The keys only start working once the home view is rendered.

When logging in, the brightness is changed to the saved value very close to the end of the startup of Sugar. It should be changed at the earliest opportunity.

Sugar 0.105.2 on Ubuntu Trusty 14.04.2.

Change History (2)

comment:1 in reply to: ↑ description Changed 6 years ago by tch

Replying to quozl:

While choosing colour, gender, and age, the brightness keys do not work. The keys only start working once the home view is rendered.

I tested and confirmed this happens.

The reason is that sugar's keyhandler is setup only after the intro screen is done [1,2] and the keyhandler depends on the existence of the frame [3], but the frame is also created after the intro [4]. This is also true for all other keys functions.

I will need more research to understand why exactly this is being done at this point.

When logging in, the brightness is changed to the saved value very close to the end of the startup of Sugar. It should be changed at the earliest opportunity.

I have sent a PR to address this issue [5].

Sugar 0.105.2 on Ubuntu Trusty 14.04.2.

Refs:

  1. https://github.com/sugarlabs/sugar/blob/master/src/jarabe/main.py#L206
  2. https://github.com/sugarlabs/sugar/blob/master/src/jarabe/main.py#L139
  3. https://github.com/sugarlabs/sugar/blob/master/src/jarabe/main.py#L93
  4. https://github.com/sugarlabs/sugar/blob/master/src/jarabe/main.py#L138
  5. https://github.com/sugarlabs/sugar/pull/527
Last edited 6 years ago by tch (previous) (diff)

comment:2 Changed 6 years ago by SAMdroid

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.