Opened 6 years ago

Closed 6 years ago

#4853 closed defect (fixed)

Journal: copy by drag to Documents or devices buttons don't work on F21

Reported by: godiard Owned by:
Priority: High Milestone: Unspecified
Component: Sugar Version: Unspecified
Severity: Major Keywords: F21
Cc: patch Distribution/OS: Unspecified
Bug Status: New

Description

This could be related to #3999, but is possible drag a item to the clipboard, then, at least the drag part is working.

In F21, when the user drag a journal item to the "Documents" or devices buttons at the bottom bar, the file is not copied.

Adding log to the code, I can see the listmodel.do_drag_data_get() is called, but volumestoolbar.py BaseButton._drag_data_received_cb is never called.

Change History (4)

comment:1 Changed 6 years ago by SAMdroid

This is not just an issue dragging to the volumestoolbar. It does not drag properly to the clipboard frame either. The frame gets data, but it is always null.

This seems to be an issue with the GtkTreeDragSource. I'm not sure what has changed - nothing in the docs.

Instead you can add a basic drag source listener to the ListView class and that will just act as a proxy to the model's drag functions. That works very well for some reason.

comment:2 Changed 6 years ago by SAMdroid

  • Cc patch added

Patch: https://github.com/sugarlabs/sugar/pull/525

This issue still occurs on Fedora 23 Rawhide (updated ~4 hours ago)

comment:3 Changed 6 years ago by SAMdroid

  • Bug Status changed from Unconfirmed to New
  • Priority changed from Unspecified by Maintainer to High
  • Severity changed from Unspecified to Major

Upstream BGO ticket: https://bugzilla.gnome.org/show_bug.cgi?id=750443

New patch (Try2): https://github.com/sugarlabs/sugar/pull/526

Note about the clipboard: Without the patch, clipboard never gets the data - so you don't get it working 100%. It just says "object id entry" or something like that. With the bug patched you get the clipboard working as done previously

comment:4 Changed 6 years ago by Gonzalo Odiard

  • Resolution set to fixed
  • Status changed from new to closed

Fix Journal ListView DnD, fixes #4853

The GtkTreeDragSource is not working for us, without changes in the
docs. This commit uses the ListView as a proxy for the old methods.

This patch is based in work from Sam Parkinson <sam.parkinson3@…>
and was tested on F18 and F22.

Changeset: b608dfe23713f3cd7eb15b392f7a9a7d3d6cb89c

Note: See TracTickets for help on using tickets.