Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#481 closed defect (notsugar)

mv command in Terminal (and Sugar console) removes files when move unsuccessful

Reported by: smiller Owned by: smiller
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Terminal Version: Unspecified
Severity: Unspecified Keywords:
Cc: bernie Distribution/OS: Unspecified
Bug Status: Needinfo

Description

When using the 'mv' to move files in the Sugar Terminal (or console), mv deletes the files being moved even if the transfer is unsuccessful. This was discovered when a USB drive was mounted read-only, and the mv command was used to transfer files. Every file was listed as unsuccessful due to lack of permissions (as expected). After re-mounting the drive with as 'rw', the files that were "moved" were gone. The 'mv' command removed them, even after completing unsuccessfully.

'mv' should be fixed to only delete the files after a successful move.

Change History (3)

comment:1 Changed 12 years ago by bernie

  • Cc bernie added
  • Owner changed from sayamindu to smiller
  • Status changed from new to assigned

I can't reproduce it. Where you moving from the USB stick or into it?
Could you please provide detailed steps of what you have done?

Anyway, if it seems like an upstream bug in mv, it should be reported to the coreutils folks.

comment:2 Changed 12 years ago by tomeu

  • Bug Status changed from Unconfimed to Needinfo

comment:3 Changed 12 years ago by tomeu

  • Resolution set to notsugar
  • Status changed from assigned to closed

In any case, there's nothing in Sugar we can do to influence this.

Note: See TracTickets for help on using tickets.