Opened 4 years ago

Last modified 4 years ago

#4783 reopened defect

Sugar fails to install on Raspberry Pi (ARM6 - PiDora)

Reported by: kieppie Owned by:
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: Unspecified
Severity: Unspecified Keywords: Raspberry Pi, PiDora, libwebkit2gtk
Cc: Distribution/OS: Fedora
Bug Status: Need Info

Description

Followed the guide provided @ http://wiki.sugarlabs.org/go/Fedora & kept this one for reference - http://wiki.sugarlabs.org/go/Sugar_Creation_Kit/sck/Advanced_Topics#Raspberry_Pi_.2F_RPi

For the most part the install seems to have gone OK, but fails for dependency: libwebkit2gtk

sudo yum -y install @sugar-desktop sugar-runner

--> Running transaction check
---> Package avahi.armv6hl 0:0.6.31-21.fc20 will be installed
---> Package sugar-toolkit-gtk3.armv6hl 0:0.100.0-1.fc20 will be installed
--> Processing Dependency: libwebkit2gtk for package: sugar-toolkit-gtk3-0.100.0-1.fc20.armv6hl
Package libwebkit2gtk is obsoleted by WebKit-devel, but obsoleting package does not provide for requirements
--> Finished Dependency Resolution
Error: Package: sugar-toolkit-gtk3-0.100.0-1.fc20.armv6hl (pidora)

Requires: libwebkit2gtk
Available: libwebkit2gtk-2.1.4-7.rpfr20.armv6hl (pidora-rpfr-updates)

libwebkit2gtk = 2.1.4-7.rpfr20

Available: libwebkit2gtk-2.2.2-2.fc20.armv6hl (pidora)

libwebkit2gtk = 2.2.2-2.fc20

Available: libwebkit2gtk-2.2.7-1.fc20.armv6hl (pidora-updates)

libwebkit2gtk = 2.2.7-1.fc20

You could try using --skip-broken to work around the problem

My Fedora-fu is not that great yet, so not sure how to resolve this bug.

Change History (3)

comment:1 Changed 4 years ago by SAMdroid

  • Resolution set to fixed
  • Status changed from new to closed

This is not a bug in sugar... this is pidora's fault for having 3 copies of libgtkwebkit2. Anyway, just try installing one webkit2:

sudo yum install libwebkit2gtk-2.2.7-1.fc20.armv6hl

comment:2 Changed 4 years ago by ignacio

  • Bug Status changed from Unconfirmed to Need Info
  • Resolution fixed deleted
  • Status changed from closed to reopened

@SAMDroid dont close it, just wait for a reply.

comment:3 Changed 4 years ago by JerryV

From the mailing list it appears that libwebkit2gtk needs to be removed from the Requires in sugar-toolkit-gtk3's spec file.

Note: See TracTickets for help on using tickets.