Opened 10 years ago

Closed 10 years ago

#4758 closed defect (fixed)

sugar 0.102: big fonts in xo

Reported by: godiard Owned by: godiard
Priority: Unspecified by Maintainer Milestone: 0.102.0
Component: Sugar Version: Unspecified
Severity: Major Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed


In the testing images for 0.102, all the text is displayed very big. The problem only is present in the xo hardware, then could be related to the different pixel size.

Attachments (3)

sugar.diff (316.9 KB) - added by godiard 10 years ago.
sugar-artwork.diff (31.5 KB) - added by godiard 10 years ago.
sugar-toolkit-gtk3.diff (130.0 KB) - added by godiard 10 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 10 years ago by godiard


in my desktop returns 98401
but in the xo returns 205339 (the same like in previous images),
then Gtk knows about the different dpi in the scree.

We are still using F18 as a base, then no other rpms have changed.

Another strange issue is if I run a gnome application, like gedit in the Sugar terminal,
the fonts are displayed in the same size than in 0.100

comment:2 Changed 10 years ago by godiard

Another strange issue, maybe related:

If I do in the terminal in the xo:
gsettings get "org.gnome.desktop.interface" "text-scaling-factor"

get 2.1000000000001

In the desktop, I get 1.0

If I want modify the value, doing:

gsettings set "org.gnome.desktop.interface" "text-scaling-factor" 1.0

no error is displayed, but when try to read the value again, get 2.1

In old images, I get 2.1, but when try modify the value, is saved ok.

comment:3 Changed 10 years ago by godiard

style.FONT_SIZE is ok too (10.0), then the config is saved in GSettings

comment:4 Changed 10 years ago by quozl

per irc,

  • not an oob issue, is isolated to the rpms, installing the rpms in old build yields same problem,
  • not an xo model issue, happens on all xo models.
Last edited 10 years ago by quozl (previous) (diff)

Changed 10 years ago by godiard

Changed 10 years ago by godiard

Changed 10 years ago by godiard

comment:5 Changed 10 years ago by godiard

As suggested by quozl, did a diff on the rpm contents, see attachments

comment:6 Changed 10 years ago by tch

Here are my finding,

To change configuration values to match sugar-build you can follow these steps:

$cd /usr/share/glib-2.0/schemas

$vi olpc.gschema.override


$vi sugar.gschema.override

    default-face='Sans Serif'

$glib-compile-schemas .

$gsettings get org.gnome.desktop.interface text-scaling-factor
$gsettings get org.sugarlabs.font default-face
$gsettings get org.sugarlabs.font default-size

After doing that, you will notice that the size of the text is just still the same size (BIG). But, if you change default-size=7 it will look OK.

If you did these steps on the build I provided [1], you will notice 2 things:

First, is that the 2.1 values comes from the override

$vi olpc.gschema.override

    # GNOME hardcodes DPI to 96, so we multiply the default scaling by 2.1 to
    # hit our DPI (201) and get appropriately sized fonts.
    # Cantarell appears to scale badly in comparison to other fonts, deviating
    # largely from the point scale. So switch the default font from Cantarell
    # to Sans to match the rest of the desktop.

Second, is that the default font is not Sugar's default.

$vi sugar.gschema.override



Version 0, edited 10 years ago by tch (next)

comment:7 Changed 10 years ago by godiard

Found the source of the problem:

In oob, the file modules/sugar/ set thee font_size in 7, but in gconf instead of gsettings. We need update that config and others in the same file.

comment:8 Changed 10 years ago by walter

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.