Opened 7 years ago

Closed 7 years ago

#4757 closed defect (fixed)

Maximum Activities notification puts home off screen

Reported by: tonyforster Owned by:
Priority: High Milestone: Unspecified
Component: Sugar Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

XO-4 Sugar 0.100 13.4.0 build1
the home screen gets pushed down by notifications

Attachments (2)

Screenshot of %22Home%22.png (146.9 KB) - added by tonyforster 7 years ago.
Screenshot of %22Home%22.2.png (79.8 KB) - added by tonyforster 7 years ago.

Download all attachments as: .zip

Change History (7)

Changed 7 years ago by tonyforster

comment:1 Changed 7 years ago by walter

  • Priority changed from Unspecified by Maintainer to Normal

comment:2 Changed 7 years ago by godiard

  • Priority changed from Normal to High

comment:3 Changed 7 years ago by walter

I cannot reproduce this bug. Could you please provide step-by-step instructions? (What I have tried on an XO 4 running 0.100.0 is to launch an activity from the Home View when the limit has been reached. What I see is an alert and no displacement of the Home View).

comment:4 Changed 7 years ago by tonyforster

Testing on build 2 XO-4
Open 4 Activities from Home screen. (I used Turtle art, Turtlebots, Log and browse)
Attempt to open another 4 or more activities from Home, do not clear the alerts.

Changed 7 years ago by tonyforster

comment:5 Changed 7 years ago by Gonzalo Odiard

  • Resolution set to fixed
  • Status changed from new to closed

Fix display of multiple alerts in home view - Fixes #4757

Copy the logic on grphics/window.py to avoid display more than one
alert at the same time.

Signed-off-by: Gonzalo Odiard <godiard@…>

Changeset: 48f9d338adb7e590fa48460d9abb36af645b7983

Note: See TracTickets for help on using tickets.