Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#4751 closed defect (fixed)

clipboard size increases on adding an object and covers a part of top frame

Reported by: curiousguy13 Owned by:
Priority: Urgent Milestone: Unspecified
Component: Sugar Version: Git as of bugdate
Severity: Major Keywords: clipboard
Cc: Distribution/OS: Fedora
Bug Status: New

Description (last modified by curiousguy13)

when we add some object to clipboard by dragging or copying, the size of clipboard increases and covers a part of the first icon of the top frame.

Attachments (1)

Screenshot from 2014-03-29 17:59:16.png (70.2 KB) - added by curiousguy13 5 years ago.

Download all attachments as: .zip

Change History (7)

Changed 5 years ago by curiousguy13

comment:1 Changed 5 years ago by curiousguy13

  • Description modified (diff)

comment:2 Changed 5 years ago by walter

  • Priority changed from Unspecified by Maintainer to Normal

comment:3 Changed 5 years ago by icarito

  • Bug Status changed from Unconfirmed to New
  • Priority changed from Normal to Urgent
  • Severity changed from Unspecified to Major

Confirmed on Manjaro (without broot).

comment:4 Changed 5 years ago by FGrose

Similar bugs: #4673, #4769

comment:5 Changed 5 years ago by Gonzalo Odiard

  • Resolution set to fixed
  • Status changed from new to closed

Fix clipboard icon size - Fixes #4751

The origi of this problem was apply the padding rule to all the objects
internal to a SugarRadioToolButton. SugarClipboardIcon inherit the rule
and is affected, because have a button and a label inside.
The label is invisible, but with the padding enlarge the button.

Manuel said asterisks should not be used in the css theme, but few are present,
this is one case one using the asterisk have unintended consequences.

Signed-off-by: Gonzalo Odiard <godiard@…>

Changeset: a3e71db389bd72468ff9143fb1e8af07c8c02972

comment:6 Changed 5 years ago by inkyfingers

This is reproducible in osbuild under Debian.

My screenshot shows a "first" clipping introducing an inappropriate oversize gray background, while a subsequent clipping appears more correctly.

The "altered" frame "left hand element" does not interfere with the F1 icon in this screenshot, but the interference happens reproducibly (depends on cursor position).

Once clippings are removed, the altered frame persists.

Note: See TracTickets for help on using tickets.