Opened 5 years ago

Last modified 5 years ago

#4743 reopened defect

missing AU translations

Reported by: JerryV Owned by:
Priority: High Milestone: Unspecified
Component: Sugar Version: Git as of bugdate
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

There are incorrect spelling for 'favourites', 'neighbourhood' for AU.
http://lists.sugarlabs.org/archive/sugar-devel/2014-March/047721.html

Change History (6)

comment:1 Changed 5 years ago by walter

  • Priority changed from Unspecified by Maintainer to High

comment:2 Changed 5 years ago by walter

If we use LANG=en_GB.utf8 is works. The problem is that there are no en_AU files in Sugar.

comment:3 Changed 5 years ago by tch

I will include en_GB in the next AU release.

My question is, should I set en_GB as the primary language for Sugar? According to my tests, if I set en_AU as primary and en_GB as secondary, it will still fallback to "en" (with USA spelling).

Last edited 5 years ago by tch (previous) (diff)

comment:4 Changed 5 years ago by tch

By the way, for what Sugar's concern, dnarvaez added en_GB to the LINGUAS list in [1], which I think is the equivalent for what it was done in DX [2].

Refs:

  1. https://github.com/sugarlabs/sugar/commit/95e302f3a9aada4be1fc396f8f25e46a65eda27c
  2. http://git.sugarlabs.org/dextrose/mainline/blobs/e08301a3efe73d5ae993b5780ba4d49973dbca53/rpms/sugar/AUlangs.diff

comment:5 Changed 5 years ago by godiard

  • Resolution set to fixed
  • Status changed from new to closed

Looks fixed (tested on 0.102)

comment:6 Changed 5 years ago by JerryV

  • Resolution fixed deleted
  • Status changed from closed to reopened

There is no en_AU.po file found at https://github.com/sugarlabs/sugar/tree/master/po, that would be the full implementation of the translation.

Note: See TracTickets for help on using tickets.