Opened 6 years ago

Closed 3 years ago

#4724 closed enhancement (fixed)

GetBooks: keep the information of the downloaded books

Reported by: manuq Owned by: manuq
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: GetBooks Version: Unspecified
Severity: Unspecified Keywords: patch
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Currently GetBooks doesn't keep the information of the downloaded books.

I think the activity should be smarter, and show "Start" instead of "Get" if the book was already downloaded and is still in the Journal.

Of course, if the book is removed from the Journal by the user, GetBooks should reflect this change, or show a message to the user if she/he is trying to start the book. This is similar to what was implemented in Jukebox playlist.

Note that I use "Start" instead of "Show in Journal" because that will change soon, and suits better with this change :)

Change History (3)

comment:2 Changed 5 years ago by godiard

  • Keywords patch added

comment:3 Changed 3 years ago by quozl

  • Resolution set to fixed
  • Status changed from new to closed

GetBooks does now provide My books, and when these are selected will launch Read.

What it doesn't yet do is block a download if the book is already in the journal. I'm not sure it should; what if the copy in the journal is corrupt? So let's close this, leaving the learner to make the decision whether to download again or use the My books list.

Note: See TracTickets for help on using tickets.