Opened 7 years ago

Closed 7 years ago

#4703 closed enhancement (fixed)

A quick way to open an activity

Reported by: martasd Owned by:
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: OLPC
Bug Status: Unconfirmed

Description

Currently, opening a new instance of an arbitrary activity involves the following steps:

  • Go to the List View
  • Press a key or use a mouse to focus the search bar
  • Type the name of the activity to launch
  • Click on the activity's icon once it appears

It would be very useful to have a way to launch an activity in fewer steps. I suggest using the search button, which currently has the same purpose as the Journal button, to bring up a dialog where one can type in the name of the activity and launch it by pressing enter (an equivalent of how one can launch an application with Alt-F2 in GNU/Linux desktop distributions). This would be an improvement over the four-step process described above.

Change History (4)

comment:1 Changed 7 years ago by walter

Why not click on Start New from the icon in the Favorites View?

comment:2 Changed 7 years ago by martasd

I would like to have a way to launch an arbitrary activity quickly. There are two issues with launching from the Favorites View:

  1. Not all activities are included in the View by default (which is of course by design), so I can't launch an arbitrary activity from there
  2. It often takes a me a while to locate the activity I am looking for in the Favorites View. I would like to simply type in an activity's name and hit enter, which is the quickest way from my point of view.

comment:3 Changed 7 years ago by walter

Re 1, I don't think it is unreasonable that it takes longer to launch an activity that is not a favorite (hence favorites) and now (Sugar 98+) that you can have multiple favorites views...

Re 2, I am sympathetic to the problem of finding activities when you have hundreds loaded on your machine (as I do), but it is not clear to me that the default after searching for an activity should be launch new as opposed to launch most recent. So...

Please start a discussion on the devel list with [DESIGN] in the subject field to see if anyone else has ideas of how we might address this issue.

Last edited 7 years ago by walter (previous) (diff)

comment:4 Changed 7 years ago by godiard

  • Resolution set to fixed
  • Status changed from new to closed

Actually (Sugar 0.102) you don't need do all the steps you describe, just:

  • Go to the list view
  • Write the activity name (don't need go to the search bar)
  • When one activity is selected, press enter.

The same is possible in the Home view too, if the activity is already a favorite.

Closing as fixed.

Note: See TracTickets for help on using tickets.