Opened 6 years ago

Closed 5 years ago

#4683 closed defect (notabug)

Active activity should move to first place in the list in the frame

Reported by: HoboPrimate Owned by:
Priority: Low Milestone: Unspecified
Component: Sugar Version: Git as of bugdate
Severity: Unspecified Keywords: design
Cc: Distribution/OS: Fedora
Bug Status: Unconfirmed

Description

This allows a kid to alt-tab consecutivelly between two activities with just one press of the combo-keys, like you can in other desktops.

This is also how it is shown at the end of the video at www.sugarlabs.org:

http://www.sugarlabs.org/index.php?template=gallery&page=media_01

Change History (2)

comment:1 Changed 5 years ago by walter

  • Priority changed from Unspecified by Maintainer to Low

I think we sorted out the alt-tab issues during GCI... will double-check that it landed.

comment:2 Changed 5 years ago by godiard

  • Resolution set to notabug
  • Status changed from new to closed

No one of the animations in that video are implemented. You can't take that as a specification.

Changing the order in the activity icons in the frame would be complicate and brake some of the conventions we have (like the journal is always the first activity, than maps to the F5 key, with all the other views).
Sugar users usually don't use a big number of activities at the same time, then pressing ALt-tab one more time should not be so common.

Closing as Not a bug

Note: See TracTickets for help on using tickets.