Opened 6 years ago

Last modified 4 years ago

#4681 new enhancement

Show icon indicating volume and brightness levels when corresponding button is pressed

Reported by: martasd Owned by:
Priority: Normal Milestone: Unspecified
Component: Sugar Version: 0.98.x
Severity: Minor Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Needs Design

Description

It would be useful if there was an icon on the screen showing the current volume or brightness level when the corresponding keyboard button is pressed. Currently, there is no indication of what the current volume level is when I change it with a button.

Change History (4)

comment:1 Changed 5 years ago by quozl

It is not enough to detect the keys.

Because of #1677, the volume change detection must be built using the ALSA API. See the alsaaudio or pyalsa modules. See also dev.laptop.org #9913.

Brightness changes will be even more complex. Sugar does not handle brightness at the moment.
Change detection might read /sys/devices/platform/dcon/backlight/dcon-bl/brightness on an XO, but on other systems it isn't clear what can be used.

comment:2 Changed 4 years ago by quozl

  • Bug Status changed from Unconfirmed to Resolved
  • Priority changed from Unspecified by Maintainer to Normal
  • Severity changed from Unspecified to Minor

Merged for 0.106. PR #511

comment:3 Changed 4 years ago by SAMdroid

  • Bug Status changed from Resolved to Needs Design

No this bug has not been fixed. Although it is visible in the frame, it is not visible after a keyboard event.

With the brightness merged, we now have the models needed to implement this. However, we do not have the UI yet. Users still must go to the frame to see this.

comment:4 Changed 4 years ago by quozl

Thanks, well spotted. Also need to fix #1677 and show volume changes.

Note: See TracTickets for help on using tickets.