Opened 5 years ago

Closed 5 years ago

#4673 closed defect (fixed)

Clipboard item palette area and size restricted

Reported by: FGrose Owned by:
Priority: Urgent Milestone: Unspecified
Component: Sugar Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Observed in Sugar 0.100.0 in SoaS 10 TC5.

Attachments (5)

latest_of_4.png (8.6 KB) - added by FGrose 5 years ago.
latest_of_4
third_of_4.png (10.6 KB) - added by FGrose 5 years ago.
third_of_4
second_of_4.png (11.8 KB) - added by FGrose 5 years ago.
second_of_4
first_of_4.png (13.3 KB) - added by FGrose 5 years ago.
first_of_4
content_text.png (40.5 KB) - added by FGrose 5 years ago.
content_text

Download all attachments as: .zip

Change History (13)

comment:1 Changed 5 years ago by godiard

Can you be more specific? Attach a screenshot would help

Changed 5 years ago by FGrose

latest_of_4

Changed 5 years ago by FGrose

third_of_4

Changed 5 years ago by FGrose

second_of_4

Changed 5 years ago by FGrose

first_of_4

Changed 5 years ago by FGrose

content_text

comment:2 Changed 5 years ago by FGrose

  • Summary changed from Clipboard item palette size restricted to Frame area to Clipboard item palette area and size restricted

Observed in sugar 0.100.2-1.fc20

A textual lines from a Terminal session were highlighted and copied with the Copy toolbar tool.

The 'latest_of_4.png' attachment shows that the latest (bottom) entity palette is restricted to the area below the bottom of its icon.

The other screenshots show a similar restriction.

The 'content_text.png' attachment shows the highlighted content in the Terminal window.

All the copies were of the same text block, with each successive copy including one additional blank line.

comment:3 follow-up: Changed 5 years ago by walter

  • Priority changed from Unspecified by Maintainer to Normal

Also see $4751

comment:4 in reply to: ↑ 3 Changed 5 years ago by FGrose

Also see #4751

comment:5 Changed 5 years ago by godiard

  • Priority changed from Normal to Urgent

comment:6 Changed 5 years ago by godiard

This issue is related to #4769.

comment:8 Changed 5 years ago by Gonzalo Odiard

  • Resolution set to fixed
  • Status changed from new to closed

Show palettes at the screen bottom with the right size - Fixes #4673

On Gtk 3.10, Gtk.Menu at the bottom of the screen are resized
to avoid fall out of the screen, then report a wrong height.
We need calculate the size of the children and move the Menu up.

This problem is visible on the Clipboard icon palettes,
and in journal objects palettes at the bottom of the screen.

This patch also rename a variable 'rect' to 'req', because is
a Requisition (width, height) and not a Rectangle (x, y, width, height).

Finally, to avoid a error with the secondary text on the palette,
when copy text from the terminal, reove the '¬r' character.

Signed-off-by: Gonzalo Odiard <godiard@…>

Changeset: b9d6b628a98fc17f5e92a344450b6336f1a2b2ce

Note: See TracTickets for help on using tickets.