Opened 7 years ago

Closed 5 years ago

Last modified 5 years ago

#4662 closed defect (fixed)

No changes are saved in Write 94 on Fedora 20 TC2

Reported by: inkyfingers Owned by: godiard
Priority: Urgent Milestone: Unspecified
Component: Write Version: 0.98.x
Severity: Critical Keywords:
Cc: Distribution/OS: Fedora
Bug Status: New

Description

Write is unusable as no changes are saved. I have never succeeded in saving anything in Write on this install.

Write 94 starts OK and text can be entered. Write will perform as expected until I attempt to rename the file.

Start Write, put cursor in Activity tab, "rename file" field, and attempt to rename, Write collapses after a variable delay, or as soon as the cursor is moved onto the "page". I have been been careful to use only ASCII characters.

For a test of minimum "load", attempt to rename file to ab, with no text in the page. Do no further keystrokes, Write collapses after a variable delay of 1 to 10 seconds.

Actually closing Write, with "original" file-name "Write Activity" is as expected, except that resume opens an empty page. Where "Write Activity, resume" appears in Home View, Write opens with a blank page.

Does behavior persist after restart and yum update? Yes.
Have I seen the "Keep error" message? Seen once, I had attempted to Insert Image, but generally Write collapses without warning.

Intermittent

It has been intermittent whether an empty "Write Activity" is seen in the Journal.

There is "resistance" to putting the cursor in Activity tab, rename file field, possibly the mouse click is not correctly recognized.

I have repeated tests with two keyboards (USB + PS/2) and two (USB) mice. PS/2 keyboard resulted in greater sense of resistance.

Environment is

Hard drive install of Fedora-Live-Xfce-x86_64-20-TC2
yum install @Sugar Desktop
with Sugar-session running

Attached Activity log and shell log.

Attachments (9)

org.laptop.AbiWordActivity-2.log (127.7 KB) - added by inkyfingers 7 years ago.
Activity log
shell.log (151.1 KB) - added by inkyfingers 7 years ago.
Shell log
16-06-2014_AbiWordActivity_x6-tests (1.2 KB) - added by inkyfingers 6 years ago.
Test sequence
16-06-2014_AbiWordActivity-1.log (8.7 KB) - added by inkyfingers 6 years ago.
16-06-2014_AbiWordActivity-2.log (8.8 KB) - added by inkyfingers 6 years ago.
16-06-2014_AbiWordActivity-3.log (8.8 KB) - added by inkyfingers 6 years ago.
16-06-2014_AbiWordActivity-4.log (5.6 KB) - added by inkyfingers 6 years ago.
16-06-2014_AbiWordActivity-5.log (9.9 KB) - added by inkyfingers 6 years ago.
16-06-2014_AbiWordActivity-6.log (5.8 KB) - added by inkyfingers 6 years ago.

Download all attachments as: .zip

Change History (21)

Changed 7 years ago by inkyfingers

Activity log

Changed 7 years ago by inkyfingers

Shell log

comment:1 Changed 7 years ago by dnarvaez

  • Priority changed from Unspecified by Maintainer to Urgent

comment:2 Changed 6 years ago by godiard

  • Component changed from Sugar to Write

comment:3 Changed 6 years ago by godiard

  • Owner set to godiard
  • Status changed from new to assigned

Changed 6 years ago by inkyfingers

Test sequence

Changed 6 years ago by inkyfingers

Changed 6 years ago by inkyfingers

Changed 6 years ago by inkyfingers

Changed 6 years ago by inkyfingers

Changed 6 years ago by inkyfingers

Changed 6 years ago by inkyfingers

comment:4 Changed 6 years ago by inkyfingers

Updated summary


Write (updated by git clone) is usable in .rtf mode with care on yum-updated SoaS.
Using Write in the default .odt mode is less successful.
Performance has improved since original bug report, but variable performance is seen.

Current testing environment

FedoraLiveSoaS-i686-20.1 hard drive install with liveinst. (Now, no xfce, no sugar-runner.)

Write git cloned as of 3 June 2014 (ie > v.94),
Fedora 20 environment yum updated, 14 June 2014,
including sugar.repo updated with http://copr.fedoraproject.org/coprs/dnarvaez/sugar/repo/fedora-20-i386,
(Tests of Write have been with Write the only Activity running.)

Testing

See a sequence of six tests attached: 16-06-2014_AbiWordActivity_x6-tests, and the six log files.

Generalized Performance Report

Write usually starts, - ok.

Activity tab, rename_file field can be edited - ok.

Tab will generally move cursor from Activity tab, rename_file field into the document - ok.

Text can be entered on document - ok.

Write does not consistently meet the expectation that on pressing the Stop button, Write will close, and work in progress can be resumed from Journal. Fail.

Pressing the Stop button causes the cursor to "run timer" for a second or two, then close, visually appropriately.

Write closes, but Resume mostly (not always) opens a blank page, mostly in the created filename.

A document can be exported as .rtf (or .html or .txt), but expect the original file to fail to resume.

Open the exported .rtf file and edit it - ok.

Now, Stop, Journal entry, and resume work satisfactorily, work can now proceed reliably with this file - ok.

It seems, Write can work successfully with .txt, .rtf, .html files, but .odt files are harder to succeed.

The ability to generate an .odt is not a total fail. Sometimes .odt documents are saved and resumed. Re-opened .odt documents might then be lost on a subsequent close. Both behaviors are seen in the test sequence attached 16-06-2014_AbiWordActivity_x6tests.

Fails

Exporting any document as .pdf causes Write to collapse.

Use Speak to read aloud text in a Write document causes Write to collapse.

Intermittent

It has continued to be intermittent whether an empty (that is, lost) "Write Activity" is seen in the Journal.

The "resistance" to putting the cursor in the Activity tab, rename_file field is less noticeable than at time of original bug report.

Sound

Characteristic sound is generated by the backspace key reaching start_of_line.
Sound, in general, is working in SoaS.

Collaboration

Write sometimes opens with the sharing icon greyed out, but not every time.
A similar thing is now seen in Chat. I relate this to intermittent collaboration availability, but it is not fully consistent with whether other_user avatars are visible in F1 View.
Activities open for sharing commonly do not throw an icon into the F1 View on my SoaS.
I do not have hardware to test collaboration in a local mesh.
I have the impression that, on days when the sharing icon is greyed out, Write may perform better.
I avoid opening the Sugar 0.100.0 session to collaboration, as I think this would increase the over-sensitivity of Write.

Speculation

This inexact behavior may be consistent with bugs ... unresolved collaboration issues, ... or unresolved sound issues hogging resources.

comment:5 Changed 6 years ago by godiard

Thanks inkyfingers for the extensive testing.

comment:6 Changed 6 years ago by quozl

Reproduced. On journal entry resume, an empty document is shown, but exporting that as HTML results in a journal entry that Browse reveals to contain the original document text.

comment:7 follow-up: Changed 6 years ago by quozl

The above comment wrong, my mistake. For Write-95 on Fedora 20:

  • when a new activity is started, text typed, then activity stopped, and then resumed from journal, the view appears blank, but the saved text is present after a page break,

If the page break is deleted, subsequent resume renders the document as it was

Sometimes the Sugar shell reports the activity failed to start, but then it starts anyway. When this happens, there is nothing unusual in the shell or activity log.

dev.laptop.org #12838

Last edited 6 years ago by quozl (previous) (diff)

comment:8 Changed 6 years ago by inkyfingers

Reproduced in Write-95 on Fedora 21:
In English, UK, a page break and a blank line are generated.
If I change to Spanish, Argentina I do not see the issue.
Other languages seem to vary.

comment:9 in reply to: ↑ 7 Changed 5 years ago by quozl

Replying to quozl:

  • when a new activity is started, text typed, then activity stopped, and then resumed from journal, the view appears blank, but the saved text is present after a page break,

Tested Write-96, this is now fixed. Thanks!

Others, please test Write-96, then ticket can close.

comment:10 Changed 5 years ago by inkyfingers

Write-96 "Saves on Close" accurately. Thank you.

comment:11 Changed 5 years ago by godiard

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed in version 96

comment:12 Changed 5 years ago by inkyfingers

Working, as comment 8 above, in Write-95 on Fedora 21_Beta_4, hard drive install.

Simple language sensitivity is not reproducible.

Under some unidentified circumstance Write seems free of overhead and saves correctly.

Note: See TracTickets for help on using tickets.