Opened 6 years ago

Closed 5 years ago

#4659 closed defect (fixed)

Activities don't start

Reported by: AlanJAS Owned by: godiard
Priority: Normal Milestone: Unspecified
Component: Sugar Version: Git as of bugdate
Severity: Critical Keywords:
Cc: godiard Distribution/OS: Unspecified
Bug Status: New

Description

The first time works. After, It gives this:

Traceback (most recent call last):

File "/home/broot/sugar-build/build/out/install/lib/python2.7/site-packages/jarabe/desktop/favoritesview.py", line 484, in button_release_event_cb

self._activate()

File "/home/broot/sugar-build/build/out/install/lib/python2.7/site-packages/jarabe/desktop/favoritesview.py", line 496, in _activate

self._resume(self._journal_entries[0])

File "/home/broot/sugar-build/build/out/install/lib/python2.7/site-packages/jarabe/desktop/favoritesview.py", line 489, in _resume

misc.resume(journal_entry, self._activity_info.get_bundle_id())

File "/home/broot/sugar-build/build/out/install/lib/python2.7/site-packages/jarabe/journal/misc.py", line 220, in resume

color=get_icon_color(metadata))

File "/home/broot/sugar-build/build/out/install/lib/python2.7/site-packages/jarabe/journal/misc.py", line 246, in launch

activity.get_window().activate(Gtk.get_current_event_time())

AttributeError: 'NoneType' object has no attribute 'activate'

Attachments (1)

shell.log (17.7 KB) - added by AlanJAS 6 years ago.
shell.log file

Download all attachments as: .zip

Change History (10)

Changed 6 years ago by AlanJAS

shell.log file

comment:1 Changed 6 years ago by AlanJAS

General steps to reproduce:
-make an activity favorite
-make the same activity no-favorite
-make favorite again
After that (generally) the activities not work

comment:2 Changed 6 years ago by dnarvaez

  • Bug Status changed from Unconfirmed to New

Do you have icons flashing in the frame when this happens?

I can't trigger it reliably but it always happens after trying a bit.

comment:3 Changed 6 years ago by AlanJAS

Yes, there is a flashing icon in the frame.
And yes, you need try a bit.

comment:4 Changed 5 years ago by godiard

I can't reproduce this issue.

Could you provide more information about the environment?

Is in a XO or in a desktop? Sugar version?

Happen more with some activities then with others?

comment:5 Changed 5 years ago by godiard

  • Cc godiard added

comment:6 Changed 5 years ago by native

I can't reproduce this issue.

Can you provide more details ?

comment:7 Changed 5 years ago by godiard

  • Priority changed from Immediate to Normal

I think this is a consequence of #4767.

Can you try to apply https://github.com/sugarlabs/sugar/pull/341 and test if solves the issue?

comment:8 Changed 5 years ago by godiard

  • Owner set to godiard
  • Status changed from new to assigned

comment:9 Changed 5 years ago by godiard

  • Resolution set to fixed
  • Status changed from assigned to closed

I think this was fixed with #4767, please reopen if needed.

Note: See TracTickets for help on using tickets.