Opened 7 years ago

Closed 7 years ago

#4657 closed defect (fixed)

some icons not shown in software update

Reported by: walter Owned by:
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: Git as of bugdate
Severity: Unspecified Keywords: AU1B
Cc: godiard Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

when running software update, some icons (including the icon for the Level activity) did not appear in the listing of activities to update.

Change History (4)

comment:1 Changed 7 years ago by walter

Hmm. Could be that Level tool was not in the build but added to the list of activities to be updated? Not sure, but the version installed after update is Version 1. Something strange going on.

comment:2 Changed 7 years ago by godiard

Deleting the activity Level before trying to do a update, show the activity to install without the icon. As the objective is be a software updater, the 99% of the cases the activities will exist, then is safe think the icon is available. In the case the icon is not available, just o not show it.

Tell me if you think we should solve this, but thinking we need get the icon from the microformat backend and from aslo backend, probably is not AU!B stuff.

comment:3 Changed 7 years ago by walter

Not a high priority. Let's leave it for now.

comment:4 Changed 7 years ago by Gonzalo Odiard

  • Resolution set to fixed
  • Status changed from new to closed

Updater: show icons for new activities - Fixes #4657

Signed-off-by: Gonzalo Odiard <godiard@…>

Changeset: 5641a0607b1911c787d7cb7588266b9c68d37813

Note: See TracTickets for help on using tickets.