Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#4656 closed defect (fixed)

copy to documents fails

Reported by: walter Owned by:
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: Unspecified
Severity: Unspecified Keywords: AU1B
Cc: godiard Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

copy to Documents fails on Sugar 100 (AU build).

the problem is that the ioctl for set the hidden attributes for:

/home/olpc/Documents/.Sugar-Metadata is "Inappropriate".

Not sure when this problem crept in (when we switched to multiselect?) or if it is also applicable to other file systems. The obvious workaround is to no set the hidden attribute on the GNU/Linux file system where it is not needed. Will prepare a patch.

Change History (4)

comment:1 Changed 7 years ago by walter

Confirmed that copying to external USBs works fine. So it seems to be isolated to ~/Documents.

comment:3 Changed 7 years ago by Walter Bender

  • Resolution set to fixed
  • Status changed from new to closed

The set hidden attribute ioctl doesn't work for
~/Documents/.Sugar-Metadata, however it is not necessary to apply the
flag, since it is a Linux file system. This patch checks to see if the
destination of the copy is ~/Documents, and if so, skips the ioctl.

Fixes #4656

Changeset: 34d52feda2f6c3bbed886b35e6931afd5bae4261

comment:4 Changed 7 years ago by Walter Bender

The set hidden attribute ioctl doesn't work for
~/Documents/.Sugar-Metadata, however it is not necessary to apply the
flag, since it is a Linux file system. This patch checks to see if the
destination of the copy is ~/Documents, and if so, skips the ioctl.

Fixes #4656

Changeset: 34d52feda2f6c3bbed886b35e6931afd5bae4261

Note: See TracTickets for help on using tickets.