Opened 7 years ago

Closed 7 years ago

#4639 closed defect (notsugar)

Sometimes caps-lock is engaged, no way to turn it off except by reboot

Reported by: carrott Owned by:
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: 0.98.x
Severity: Unspecified Keywords:
Cc: Distribution/OS: Dextrose
Bug Status: Unconfirmed

Description

On XO-system 1a for XO-4 (build 49) I sometimes find that caps-lock is enabled. This XO has no caps-lock key so it's a bit of a mystery how this happens. I think it is some key combination that I accidentally press. It usually happens at least once per day of reasonable use and I don't know how to turn it off except by rebooting the laptop.

When this caps lock mode is enabled, the shift key allows entry of lower case characters, so it really seems to be acting like a real caps lock.

Change History (3)

comment:1 Changed 7 years ago by carrott

Right after raising this ticket, I find fn-hand toggles caps-lock. Is this a bug or a feature?

comment:2 Changed 7 years ago by walter

I think this was introduced as a "feature" in some builds. It is not a Sugar (or OLPC) feature as far as I know. I think the behavior should be reverted.

comment:3 Changed 7 years ago by dnarvaez

  • Resolution set to notsugar
  • Status changed from new to closed

I don't think this a sugar upstream bug.

Note: See TracTickets for help on using tickets.