Opened 10 years ago

Closed 8 years ago

#4627 closed defect (fixed)

Terminal: crash on 13.2.0

Reported by: godiard Owned by: godiard
Priority: High Milestone: Unspecified
Component: Terminal Version: Unspecified
Severity: Unspecified Keywords: AU
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Testing in AU1B image, but saw also on sugar-build.

Need more information.

Attachments (2)

terminal-segfault-gdb.txt (93.3 KB) - added by carrott 10 years ago.
transcript of gdb session of crashed terminal
4627-workaround.patch (495 bytes) - added by quozl 10 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 10 years ago by godiard

The acitivity finish with a "Terminated by signal 11" final message in the log,
many times, when the user switch to another activity or the home view.

comment:2 Changed 10 years ago by godiard

  • Priority changed from Unspecified by Maintainer to High

comment:3 Changed 10 years ago by godiard

Check if is not related to #4131

Changed 10 years ago by carrott

transcript of gdb session of crashed terminal

comment:4 Changed 10 years ago by carrott

I see this a lot, to the point that terminal is basically unusable if used with another activity. You can debug this by logging in with ssh and attaching to terminal with gdb. You will need to install some debuginfo packages.

See the attached terminal-segfault-gdb.txt for the transcript of such a session on Terminal 42 on XO-system 1a for XO-4 (build 49).

I don't have all of the debug-info packages installed, but we can see the problem occurs at

Frame 0x8d61a0, for file /home/olpc/Activities/Terminal.activity/terminal.py, line 424, in write_file

Last edited 10 years ago by carrott (previous) (diff)

Changed 10 years ago by quozl

comment:5 follow-up: Changed 10 years ago by quozl

I don't understand why, but the attached patch, which provides an empty dictionary to get_text() in place of the None argument, prevents the segmentation fault.

comment:6 in reply to: ↑ 5 Changed 10 years ago by godiard

Replying to quozl:

I don't understand why, but the attached patch, which provides an empty dictionary to get_text() in place of the None argument, prevents the segmentation fault.

Did you tried this patch with more than one tab opened in the terminal? looks like still crash. Any idea?

comment:7 Changed 10 years ago by godiard

  • Keywords AU1B removed

In AU1B I am including a version of terminal patched to not get the terminal text, to avoid the crash.

http://dev.laptop.org/~gonzalo/activities/Terminal-42.1.xo

Remove the AU1B keyword, but this need be solved upstream.

comment:8 Changed 9 years ago by godiard

  • Keywords AU added

comment:9 Changed 8 years ago by quozl

  • Resolution set to fixed
  • Status changed from new to closed

Can't reproduce, it appears to be fixed. Closing.

Note: See TracTickets for help on using tickets.