Opened 6 years ago

Closed 6 years ago

#4610 closed defect (fixed)

Some applets in My settings doesn't work

Reported by: DeepakMuddha Owned by: Walter
Priority: Urgent Milestone: Unspecified
Component: Sugar Version: Unspecified
Severity: Major Keywords: AU1B
Cc: DeepakMuddha, godiard Distribution/OS: Unspecified
Bug Status: Assigned

Description

"Modem configuration" and "keyboard" applets doesn't work in My settings

To reproduce:

  1. click on my settings option
  2. All the applets will display
  3. Now click on modem configuration or keyboard applet

This was tested using new rpms for AU1B

Attachments (1)

shell.log (1.3 MB) - added by DeepakMuddha 6 years ago.

Download all attachments as: .zip

Change History (8)

Changed 6 years ago by DeepakMuddha

comment:1 Changed 6 years ago by walter

Not sure what is going on with the modem but it seems we are missing a patch for the keyboard. I'll test locally to confirm.

comment:2 Changed 6 years ago by godiard

As reported in the mail, the gconf modem configuration changed, the plan before was a string, now is a integer.

Try doing:

gconftool-2 --set /desktop/sugar/network/gsm/plan --type int 2

comment:3 Changed 6 years ago by walter

  • Resolution set to wontfix
  • Status changed from new to closed

The keyboard setting issue is related to backporting to Fedora 18. Since we don't need this for the AU build, no point in trying to fix it.

comment:4 Changed 6 years ago by DeepakMuddha

  • Bug Status changed from New to Assigned
  • Resolution wontfix deleted
  • Status changed from closed to reopened

I found that Modem configuration applet not working in AU build 21.

It worked fine in build 18

comment:5 Changed 6 years ago by godiard

  • Cc godiard added; Gonzalo removed

comment:6 Changed 6 years ago by godiard

1382448851.585678 DEBUG root: FriendsTray._set_current_activity
1382448851.589680 WARNING root: _Account.__set_current_activity_cb
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/jarabe/controlpanel/gui.py", line 365, in __select_option_cb
    self.show_section_view(option)
  File "/usr/lib/python2.7/site-packages/jarabe/controlpanel/gui.py", line 259, in show_section_view
    self._options[option]['alerts'])
  File "/usr/share/sugar/extensions/cpsection/modemconfiguration/view.py", line 136, in __init__
    current_plan = self.service_providers.get_plan()
  File "/usr/share/sugar/extensions/cpsection/modemconfiguration/model.py", line 393, in get_plan
    self._plans[self._current_plan])
IndexError: list index out of range
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/jarabe/controlpanel/gui.py", line 313, in __cancel_clicked_cb
    self._section_view.undo()
AttributeError: 'NoneType' object has no attribute 'undo'
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/jarabe/controlpanel/gui.py", line 319, in __accept_clicked_cb
    self._section_view.apply()
AttributeError: 'NoneType' object has no attribute 'apply'
1382449304.466588 DEBUG root: autoconnect Sugar Ad-hoc: already connected

comment:7 Changed 6 years ago by godiard

  • Resolution set to fixed
  • Status changed from reopened to closed

Solved in build 22

Note: See TracTickets for help on using tickets.