Opened 12 years ago

Closed 12 years ago

Last modified 8 years ago

#461 closed defect (fixed)

Sometimes an activity will not start

Reported by: erikos Owned by: erikos
Priority: Unspecified by Maintainer Milestone:
Component: Sugar Version: Git as of bugdate
Severity: Blocker Keywords: r+
Cc: tomeu, sascha_silbe, alsroot Distribution/OS: Unspecified
Bug Status: New

Description

With patches from #282 applied I do test 'sugar-emulator -s 72' and sometimes an activity will not start. Nothing in the logs besides:

1235985553.237079 DEBUG root: None launched in 0.004011 seconds.

I could not reproduce yet with 'sugar-emulator -s 100'. I did always erase the ~/.sugar/ before testing.

Attachments (3)

none.png (31.5 KB) - added by erikos 12 years ago.
the launcher is flashing but the activity is not launched
sugar-461.patch (1005 bytes) - added by alsroot 12 years ago.
workaround fix
0001-Take-into-account-launcher-windows-when-checking-if.patch (1.8 KB) - added by tomeu 12 years ago.

Download all attachments as: .zip

Change History (11)

Changed 12 years ago by erikos

the launcher is flashing but the activity is not launched

comment:1 Changed 12 years ago by tomeu

Maybe a dupe of #426?

comment:2 Changed 12 years ago by erikos

  • Bug Status changed from Unconfimed to New

Nope I actually still see this. And I just reproduced it (with SCALING 100) when checking #426. So I did start Terminal and restarted it again from the home view and closed it then. Then I started Write (it did not have an entry in the Journal yet) and I saw the pulsing launcher but no start - like described above.

comment:3 Changed 12 years ago by sascha_silbe

  • Cc sascha_silbe added

comment:4 Changed 12 years ago by alsroot

  • Cc alsroot added

comment:5 follow-up: Changed 12 years ago by alsroot

  • Keywords r? added

there is a race condition between ActivateActivity()[1] invoking from sugar-toolkit/src/sugar/activity/activityfactory.py:_launch_activity() and add_launcher()[2] invoking from sugar/src/jarabe/view/palettes.py:start_activate_cb():

  • [2] creates new launcher window
  • this window could be(still) not-registered before invoking [1]

attached patch adds workaround code(for 0.84 release only) - creating activity in any case(launcher window was registered or not)

Changed 12 years ago by alsroot

workaround fix

comment:6 in reply to: ↑ 5 Changed 12 years ago by tomeu

Replying to alsroot:

there is a race condition between ActivateActivity()[1] invoking from sugar-toolkit/src/sugar/activity/activityfactory.py:_launch_activity() and add_launcher()[2] invoking from sugar/src/jarabe/view/palettes.py:start_activate_cb():

  • [2] creates new launcher window
  • this window could be(still) not-registered before invoking [1]

Thanks for the analysis, seems to be right.

Your patch fixes the race, but doesn't take into account switching to an existing instance. The one I'm attaching should work for that as well.

comment:7 Changed 12 years ago by tomeu

  • Keywords r+ added; r? removed
  • Resolution set to fixed
  • Status changed from new to closed

r+'ed in #sugar by Simon and Aleksey.

Fixed by http://git.sugarlabs.org/projects/sugar/repos/mainline/commits/a4dad1b0

Thanks a lot to Aleksey for tracking this one down.

comment:8 Changed 8 years ago by godiard

  • Milestone 0.84 deleted

Milestone 0.84 deleted

Note: See TracTickets for help on using tickets.