Opened 8 years ago

Closed 7 years ago

#4598 closed defect (fixed)

Background doesn't work in My Settings

Reported by: callkalpa Owned by:
Priority: Normal Milestone: Unspecified
Component: Sugar Version: Unspecified
Severity: Unspecified Keywords: background, mysettings
Cc: Distribution/OS: Unspecified
Bug Status: New

Description

When I click on "Background" in "My Setting" nothing seems to happen. Sugar just stops responding to any input.

Attachments (2)

shell.log (1.2 KB) - added by callkalpa 8 years ago.
shell file of the operation
shell.2.log (10.3 KB) - added by callkalpa 8 years ago.
shell.log with debug on

Download all attachments as: .zip

Change History (15)

Changed 8 years ago by callkalpa

shell file of the operation

Changed 8 years ago by callkalpa

shell.log with debug on

comment:1 Changed 8 years ago by dnarvaez

  • Bug Status changed from Unconfirmed to New
  • Priority changed from Unspecified by Maintainer to Urgent

comment:2 Changed 8 years ago by dnarvaez

  • Priority changed from Urgent to Normal

I cannot reproduce. Can you please try with latest sugar-build master (see my email on the list on how to upgrade) and see if you can still reproduce?

comment:3 Changed 8 years ago by callkalpa

I tried with the master in sugar-build, still the issue is there.

comment:4 Changed 8 years ago by callkalpa

I tried with the master in sugar-build, still the issue is there.

comment:5 follow-up: Changed 7 years ago by godiard

Callkalpa,

I can't see anything relevant in the logs.

Is possible you have a lot of images in Documents folder?

If that is the case, can you wait, and see if that solve the issue?


comment:6 in reply to: ↑ 5 Changed 7 years ago by callkalpa

Replying to godiard:

Callkalpa,

I can't see anything relevant in the logs.

Is possible you have a lot of images in Documents folder?

There are only three images in the ~/Documents directory. But there are a lot deep in the directory tree under ~/Documents. Would that have an effect?

If that is the case, can you wait, and see if that solve the issue?

So far, it is not. It freezes and nothing else happens or can be done.


comment:7 Changed 7 years ago by walter

The Background widget looks for all the images in the tree, so if it is large, it will take some time.

comment:8 Changed 7 years ago by callkalpa

That may be the case. It takes a lot of time though, may be due to my too deep and wide spread directory tree.

comment:9 follow-up: Changed 7 years ago by walter

Did it display the Watch (busy) cursor?

comment:10 in reply to: ↑ 9 Changed 7 years ago by callkalpa

Replying to walter:

Did it display the Watch (busy) cursor?

Nope

comment:11 Changed 7 years ago by walter

Then that is a bug. It should be displaying the watch cursor. Please remind me what build you are testing?

comment:12 Changed 7 years ago by callkalpa

It is 0.99.0

comment:13 Changed 7 years ago by walter

  • Resolution set to fixed
  • Status changed from new to closed

I think the busy cursor is in Sugar 100. If you could test one of the new builds t o see if you can reproduce this bug, please reopen this ticket.

https://github.com/walterbender/sugar/commit/3ff0390431cfb44e86bb182386010d2628f1c7f6

Note: See TracTickets for help on using tickets.