Opened 10 years ago

Closed 7 years ago

Last modified 6 years ago

#456 closed defect (obsolete)

Browse hangs when trying to open file:///home/...

Reported by: walter Owned by: erikos
Priority: High Milestone:
Component: Browse Version: 0.83.x
Severity: Minor Keywords:
Cc: tomeu Distribution/OS: Ubuntu
Bug Status: Assigned

Description

Running an up-to-date jhbuild on Ubuntu with Browse 103, I ran into this error trying to browse my home directory:

1235833249.305326 ERROR root: Traceback (most recent call last):

File "/home/walter/sugar-jhbuild/install/lib/python2.5/site-packages/sugar/presence/presenceservice.py", line 522, in get_preferred_connection

bus_name, object_path = self._ps.GetPreferredConnection()

File "/var/lib/python-support/python2.5/dbus/proxies.py", line 140, in call

keywords)

File "/var/lib/python-support/python2.5/dbus/connection.py", line 607, in call_blocking

message, timeout)

DBusException: org.laptop.Sugar.Presence.NotFound: Traceback (most recent call last):

File "/var/lib/python-support/python2.5/dbus/service.py", line 696, in _message_cb

retval = candidate_method(self, *args, keywords)

File "/home/walter/sugar-jhbuild/install/share/sugar-presence-service/presenceservice.py", line 759, in GetPreferredConnection

raise NotFoundError('No connection is available')

NotFoundError: org.laptop.Sugar.Presence.NotFound: No connection is available

Change History (15)

comment:1 Changed 10 years ago by erikos

  • Bug Status changed from Unconfimed to Assigned
  • Milestone changed from Unspecified by Release Team to 0.84
  • Priority changed from Unspecified by Maintainer to High
  • Severity changed from Unspecified to Major

Ok, I see this as well on Soas - have to find out what the issue is here.

comment:2 Changed 10 years ago by tomeu

  • Severity changed from Major to Blocker

comment:3 follow-up: Changed 10 years ago by tomeu

Seems to be caused by Mozilla initializing libgnome implicitly so it can use gnome-vfs to query for icons to display the files.

We can workaround this issue by initializing lbgnome ourselves in webactivity.py:

diff --git a/webactivity.py b/webactivity.py
index a0ee38f..e163d9c 100644
--- a/webactivity.py
+++ b/webactivity.py
@@ -31,6 +31,9 @@ import sqlite3
 import cjson
 import gconf
 
+import gnome
+gnome.init('Browse-dummy', 'version-dummy')
+
 from sugar.activity import activity
 from sugar.graphics import style
 import telepathy

comment:4 in reply to: ↑ 3 Changed 10 years ago by tomeu

Replying to tomeu:

Seems to be caused by Mozilla initializing libgnome implicitly so it can use gnome-vfs to query for icons to display the files.

Confirmed: https://bugzilla.mozilla.org/show_bug.cgi?id=486925

We can workaround this issue by initializing lbgnome ourselves in webactivity.py:

diff --git a/webactivity.py b/webactivity.py
index a0ee38f..e163d9c 100644
--- a/webactivity.py
+++ b/webactivity.py
@@ -31,6 +31,9 @@ import sqlite3
 import cjson
 import gconf
 
+import gnome
+gnome.init('Browse-dummy', 'version-dummy')
+
 from sugar.activity import activity
 from sugar.graphics import style
 import telepathy

comment:5 Changed 10 years ago by tomeu

  • Milestone changed from 0.84 to 0.86
  • Severity changed from Blocker to Minor

comment:6 follow-up: Changed 10 years ago by alsroot

In jhconvert distros I wrapped this hack to try...except
I guess fetching python-gnome only for this workaround code is a bad idea

comment:7 in reply to: ↑ 6 ; follow-up: Changed 10 years ago by alsroot

Replying to alsroot:

In jhconvert distros I wrapped this hack to try...except
I guess fetching python-gnome only for this workaround code is a bad idea

at least on gentoo with xulrunner-{1.9.0.8,1.9.1_beta3} Browse shows file:/// well w/o this hack

comment:8 in reply to: ↑ 7 ; follow-up: Changed 10 years ago by tomeu

Replying to alsroot:

Replying to alsroot:

In jhconvert distros I wrapped this hack to try...except
I guess fetching python-gnome only for this workaround code is a bad idea

at least on gentoo with xulrunner-{1.9.0.8,1.9.1_beta3} Browse shows file:/// well w/o this hack

Sounds good, this hack is needed only in platforms where xulrunner is built with gnomevfs. I hope that Mozilla drops completely gnomevfs in their next release:

We can track this progress here: https://bugzilla.mozilla.org/show_bug.cgi?id=455231

comment:9 in reply to: ↑ 8 Changed 10 years ago by tomeu

comment:10 Changed 10 years ago by tomeu

  • Milestone changed from 0.86 to 0.88

The upstream bug has been pushed but I'm not sure it will make 0.86.

comment:11 follow-up: Changed 9 years ago by erikos

  • Cc tomeu added

Is this ticket still open, to track the upstream bug? Or to remove the code again we added as workaround?

comment:12 in reply to: ↑ 11 Changed 9 years ago by tomeu

Replying to erikos:

Is this ticket still open, to track the upstream bug? Or to remove the code again we added as workaround?

Both things!

comment:13 Changed 8 years ago by RafaelOrtiz

Update: the upstream bug has been fixed, but we cannot remove the workaround yet,
because it needs gvs/gio migration, that we don't have yet.


comment:14 Changed 7 years ago by manuq

  • Resolution set to obsolete
  • Status changed from new to closed

This is obsolete, the workaround was removed in the port to PyGI, commit dec602fda0890bdbfb121107b9bb39f7954a9cd5 . Closing.

comment:15 Changed 6 years ago by dnarvaez

  • Milestone 0.88 deleted

Milestone 0.88 deleted

Note: See TracTickets for help on using tickets.