Opened 8 years ago

Closed 8 years ago

#4539 closed defect (fixed)

keyboard section crashes in F19

Reported by: walter Owned by:
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: Git as of bugdate
Severity: Unspecified Keywords: F19
Cc: Distribution/OS: Fedora
Bug Status: Unconfirmed

Description

Peter Robinson reported that the keyboard section of the control panel does not open. This is because the byte arrays passed to _item_str are of type list rather than type string so the attempt to find the end of the string with index fails since list type has not attribute index.

A patch has been pushed [1]

[1] https://github.com/sugarlabs/sugar/pull/51

Change History (1)

comment:1 Changed 8 years ago by walter

  • Resolution set to fixed
  • Status changed from new to closed

Fixed with https://github.com/sugarlabs/sugar/commit/ff67d48d6e0a8ccfd025d355d18320dd2de458ae

(Used Xkl get_description() and get_name() to avoid ugly conversion.)

tip-o-hat to dnarvaez

Note: See TracTickets for help on using tickets.