Opened 8 years ago

Closed 8 years ago

#4524 closed defect (fixed)

Speak have a saving error in ebook mode

Reported by: godiard Owned by: RafaelOrtiz
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Speak Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Steps to reproduce:

  • Put the xo in ebook mode
  • Start a new instance of the Speak activity
  • Close the activity

The activity show a error trying to save.

Change History (2)

comment:1 Changed 8 years ago by godiard

The code:

activity.py

     def save_instance(self, file_path):
271         if self._tablet_mode:
272             if 'history' in self.cfg:
273                 history = self.cfg['history']  # retain old history
274             else:
275                 history = []
276         else:
277             history = [unicode(i[0], 'utf-8', 'ignore') \
278                            for i in self.entrycombo.get_model()]

Gives error in line 272, because for a new instance self.cfg does not exist

comment:2 Changed 8 years ago by godiard

  • Resolution set to fixed
  • Status changed from new to closed

Fixed as b31472db7f9cf6f09c2faa67f0084e121851519b

Note: See TracTickets for help on using tickets.