Opened 8 years ago

Closed 8 years ago

#4494 closed defect (duplicate)

sugar-activity: Activity bundle path should be prepended to sys.path

Reported by: gaudenz Owned by: erikos
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: Unspecified
Severity: Major Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: New

Description

The bundle_path should be prepended to sys.path in sugar-activity instead of appending it. Modules from the bundle should take precedence over the same modules already in the system path.

This is important for activities installed from system packages which are updated by the user. Otherwise the activity class is taken from the users Activity folder while the modules are imported from the system package.

Change History (3)

comment:1 Changed 8 years ago by godiard

erikos, I don't remember what was the logic here. Can you confirm?

comment:2 Changed 8 years ago by dnarvaez

  • Component changed from sugar-toolkit-gtk3 to Sugar

comment:3 Changed 8 years ago by dnarvaez

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #2965

Note: See TracTickets for help on using tickets.