Opened 8 years ago

Closed 8 years ago

#4492 closed defect (duplicate)

keyboard section of Sugar Control Panel only partly ported to Introspection

Reported by: walter Owned by: erikos
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: Git as of bugdate
Severity: Unspecified Keywords: controlpanel keyboard
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

It won't open in part because xklavier is not using GTK3
Switching to Xkl works. Numerous other small changes made in the attached patch, but still blocking on GConf.Client.set_list not being available through introspection [1]

[1] https://bugzilla.gnome.org/show_bug.cgi?id=681433

Attachments (1)

0001-finish-conversion-to-introspection.patch (5.2 KB) - added by walter 8 years ago.
mostly works... just won't save to gconf

Download all attachments as: .zip

Change History (4)

Changed 8 years ago by walter

mostly works... just won't save to gconf

comment:2 Changed 8 years ago by walter

[1] is used to fix the gconf bug. In addition, [2] fixes a problem with selecting language (it used the language in ~/.i18n as its preference)

[1] https://github.com/sugarlabs/sugar-toolkit-gtk3/commit/79fa03e846d4a816790bb589de3d7ee0ca52520d

[2] https://github.com/sugarlabs/sugar/pull/32

comment:3 Changed 8 years ago by walter

  • Resolution set to duplicate
  • Status changed from new to closed

Closing as this is (essentially) a duplicate of #3926

Note: See TracTickets for help on using tickets.