Opened 8 years ago

Closed 8 years ago

#4482 closed defect (fixed)

Collaboration works only way in "Write"

Reported by: ajay_garg Owned by: godiard
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Write Version: Unspecified
Severity: Unspecified Keywords:
Cc: ajay_garg Distribution/OS: Fedora
Bug Status: Unconfirmed

Description

1.
Open write activity in XO-A (Host machine)

2.
Click on the neighbourhood option in the activity tab to share the activity.

3.
Join the write activity on the other XO which was shared by XO-A.

4.
Now two xo machines (XO-A and XO-B) are on write activity

5.
Wait for 5-10 sec, then start typing on XO-A machine

Result: Words which are typed on XO-A machine appeared in XO-A as well as in XO-B' machine

6.
Now type some words on XO-B machine.

Result: Words which are typed on XO-B's machine appeared only in XO-B machine but not in XO-A machine

Expected result: Words which are typed in XO-B machine should appear in XO-B's machine as well as XO-A's machine

Change History (5)

comment:1 Changed 8 years ago by ajay_garg

  • Cc ajay_garg added

comment:2 follow-up: Changed 8 years ago by godiard

What xo model are you using? (I think this is a xo-4 only issue, then probably is something in the network stack). Can you confirm?

comment:3 in reply to: ↑ 2 ; follow-up: Changed 8 years ago by ajay_garg

Replying to godiard:

What xo model are you using?

In the description, XO-A is a XO-1.75 (non-touch). and XO-B is a XO-4 (touch).

(I think this is a xo-4 only issue, then probably is something in the network stack). Can you confirm?

Well, don't think it is a XO-4 is a issue only, because if I reset to
https://git.sugarlabs.org/write/mainline/commit/4e2f2e946fdfc19ef9798d35c702803d69f8bad1, build the activity, and re-deploy on both the XOs, collaboration works fine both ways.

comment:4 in reply to: ↑ 3 Changed 8 years ago by godiard

Replying to ajay_garg:

Replying to godiard:

What xo model are you using?

In the description, XO-A is a XO-1.75 (non-touch). and XO-B is a XO-4 (touch).

(I think this is a xo-4 only issue, then probably is something in the network stack). Can you confirm?

Well, don't think it is a XO-4 is a issue only, because if I reset to
https://git.sugarlabs.org/write/mainline/commit/4e2f2e946fdfc19ef9798d35c702803d69f8bad1, build the activity, and re-deploy on both the XOs, collaboration works fine both ways.

Thanks. This is a good data. Let me try.

comment:5 Changed 8 years ago by godiard

  • Resolution set to fixed
  • Status changed from new to closed

Solved on Write 90

Note: See TracTickets for help on using tickets.