Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#4444 closed defect (fixed)

My Settings panel drops out of the screen after the screen is rotated

Reported by: manuq Owned by: erikos
Priority: Unspecified by Maintainer Milestone:
Component: Sugar Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Attachments (1)

0001-account-for-size-change-when-rotating-between-landsc.patch (3.0 KB) - added by manuq 8 years ago.
Patch based on Walter one, fixes the columns number after screen rotate

Download all attachments as: .zip

Change History (4)

comment:1 Changed 8 years ago by manuq

Walter's patch fixes the issue.

The only thing I see is that the table that contains the section icons does not update its columns number after the screen rotate, having the CP panel open. Even with the conditional that Walter added, that calls table resize() . I logged the table size after that call with:

_logger.debug("TABLE SIZE %r", self._table.get_size())

And it is always 3. Maybe this is because set_size() is deprecated:
http://developer.gnome.org/gtk3/stable/GtkTable.html#gtk-table-resize

What works for me is removing the table elements and add them again. Patch attached.

Changed 8 years ago by manuq

Patch based on Walter one, fixes the columns number after screen rotate

comment:2 Changed 8 years ago by erikos

  • Resolution set to fixed
  • Status changed from new to closed

Pushed to master: 692c95f3fc673e039e56ab1f4ae538964031db89

comment:3 Changed 8 years ago by dnarvaez

  • Milestone 1.0 deleted

Milestone 1.0 deleted

Note: See TracTickets for help on using tickets.