Opened 8 years ago

Closed 7 years ago

#4432 closed defect (wontfix)

Toolbar overflow icon does not pop-down menu on touch

Reported by: greenfeld Owned by: erikos
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: 0.98.x
Severity: Unspecified Keywords:
Cc: manuq Distribution/OS: OLPC
Bug Status: Unconfirmed

Description

The Toolbar overflow icon does not reliably pop-down a menu when accessed via touch. While it is reasonably possible (although sometimes hard) to touch the icon (#4192), it just highlights itself and never seems to do anything in all the activities I tried making it appear in by rotating the screen on a XO-4 (Physics, TurtleArt, Write, etc.).

When accessed with a mouse the overflow menu appears/disappears as expected.

Seen in OLPC 13.1.0 os30.

Change History (2)

comment:1 Changed 8 years ago by manuq

  • Cc manuq added

comment:2 Changed 7 years ago by walter

  • Resolution set to wontfix
  • Status changed from new to closed

[17:50] <walterbender> #4432 needs updating... both the examples are obsolete.
[17:50] <mystery828> okay
[17:51] <mystery828> walterbender: they're obsolete? meaning?
[17:51] <walterbender> meaning that Turtle and Physics don't generate overflow palettes so the overflow button doesn't appear
[17:52] <walterbender> I need to find a new activity to test
[17:52] <walterbender> but I suspect the problem is GTK 2 activities... which we won't fix
[17:52] <walterbender> I'll write something up for this ticket

I suspect this is GTK2-related. If you can replicate with a GTK3 app, please reopen

Note: See TracTickets for help on using tickets.