Opened 8 years ago

Closed 7 years ago

#4431 closed defect (notabug)

Issues when trying to copy certain images

Reported by: erikos Owned by: manuq
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Browse Version: Unspecified
Severity: Unspecified Keywords:
Cc: humitos Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

One example: http://upload.wikimedia.org/wikipedia/commons/2/2d/Rafaelcorrea08122006.jpg

(sugar-activity:1160): Gdk-CRITICAL **: gdk_device_get_source: assertion `GDK_IS_DEVICE (device)' failed

(sugar-activity:1160): Gdk-CRITICAL **: gdk_device_get_source: assertion `GDK_IS_DEVICE (device)' failed
Traceback (most recent call last):
  File "/home/olpc/Activities/Browse.activity/palettes.py", line 286, in __copy_activate_cb
    data = urllib2.urlopen(self._url).read()
  File "/usr/lib/python2.7/urllib2.py", line 126, in urlopen
    return _opener.open(url, data, timeout)
  File "/usr/lib/python2.7/urllib2.py", line 406, in open
    response = meth(req, response)
  File "/usr/lib/python2.7/urllib2.py", line 519, in http_response
    'http', request, response, code, msg, hdrs)
  File "/usr/lib/python2.7/urllib2.py", line 444, in error
    return self._call_chain(*args)
  File "/usr/lib/python2.7/urllib2.py", line 378, in _call_chain
    result = func(*args)
  File "/usr/lib/python2.7/urllib2.py", line 527, in http_error_default
    raise HTTPError(req.get_full_url(), code, msg, hdrs, fp)
urllib2.HTTPError: HTTP Error 403: Forbidden
1361199277.624509 DEBUG root: ActivityService.set_active: 0.
1361199277.625800 DEBUG root: Activity.save: 'b2d7d1e9

It works fine for me with Firefox on my dev machine.

Change History (3)

comment:1 follow-up: Changed 8 years ago by humitos

  • Cc humitos added

I couldn't reproduce this issue in a fresh installation of build 30.

The steps that I followed:

  1. Open Browse
  2. Type this ticket url
  3. Click on the link in the description
  4. Right-click on the image
  5. Click on "Copy image" from the palette
  6. Wait some seconds (it seems the UI is blocked while the image is being downloaded)
  7. Click on the icon from the clipboard frame
  8. Click in "Open"
  9. Click in "Paste" from Edit Toolbar in Paint

comment:2 in reply to: ↑ 1 Changed 8 years ago by erikos

Replying to humitos:

I couldn't reproduce this issue in a fresh installation of build 30.

It does not seem to reproduce always. But I have seen it on os30. I have seen it with images I try to copy from wikipedia. I click on the image until I only see the image in Browse and then right click on it to get the Palette for copying.

The steps that I followed:

  1. Open Browse
  2. Type this ticket url
  3. Click on the link in the description
  4. Right-click on the image
  5. Click on "Copy image" from the palette

When I have seen it, after that step I did not get a clipboard entry and had the trace in the log.

  1. Wait some seconds (it seems the UI is blocked while the image is being downloaded)
  2. Click on the icon from the clipboard frame
  3. Click in "Open"
  4. Click in "Paste" from Edit Toolbar in Paint

comment:3 Changed 7 years ago by manuq

  • Resolution set to notabug
  • Status changed from new to closed

Couldn't repro. I think the "HTTP Error 403: Forbidden" has nothing to do with Browse.

Note: See TracTickets for help on using tickets.