Opened 8 years ago

Closed 8 years ago

#4428 closed defect (fixed)

Unable to exit Etoys

Reported by: RafaelOrtiz Owned by:
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: untriaged Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Sugar Activity: Etoys v 113

Steps to Reproduce:

  1. Open Etoys activity from Home/List View
  2. Perform a few operations
  3. Click on 'X' button on top right of the activity menu

Expected Result: Etoys Activity should exit without any errors

Actual Result: Etoys Activity does not exit; neither from the activity menu, nor from 'Stop' option from the frame.
System has to be rebooted to exit from Etoys!

Evidence: Screenshot and Logs attached

Attachments (4)

Exit Etoys.png (5.1 KB) - added by RafaelOrtiz 8 years ago.
shell.log (5.1 KB) - added by RafaelOrtiz 8 years ago.
org.vpri.EtoysActivity-1.log (5.1 KB) - added by RafaelOrtiz 8 years ago.
Etoys.txt (4.3 KB) - added by RafaelOrtiz 8 years ago.

Download all attachments as: .zip

Change History (7)

Changed 8 years ago by RafaelOrtiz

Changed 8 years ago by RafaelOrtiz

Changed 8 years ago by RafaelOrtiz

Changed 8 years ago by RafaelOrtiz

comment:1 Changed 8 years ago by manuq

I couldn't reproduce in olpc latest build.

comment:2 Changed 8 years ago by bert

That log is about Etoys trying to read the Sugar user name.

What does your .gconf/desktop/sugar/user/%gconf.xml look like?

OTOH, this error should happen at the startup of Etoys, not when quitting. Are you sure this log is produced after pressing the exit button, not before?

Also, when Etoys "hangs" after pressing the exit button (does it?), try pressing alt-period ("alt" + ".") which is Etoys' "user interrupt" key. That should also dump the stack in the log file, and would show what exactly Etoys is doing. Of course, you're welcome to press the "debug" button in the pink interrupt dialog and take a look around ;)

comment:3 Changed 8 years ago by RafaelOrtiz

  • Resolution set to fixed
  • Status changed from new to closed

Not being able to reproduce anymore.

Note: See TracTickets for help on using tickets.