Opened 7 years ago

Closed 6 years ago

#4410 closed defect (fixed)

Pressing Discard network history removes wired networking even after reboot

Reported by: FGrose Owned by: dnarvaez
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: Fedora
Bug Status: New

Description (last modified by FGrose)

Observed on Fedora 18 and SoaS 8.

In Fedora 18 Sugar in a window the wired networking switch widget on the GNOME desktop bar is turned off.

In SoaS we need a way to restart the networking.

Change History (13)

comment:1 Changed 7 years ago by FGrose

  • Bug Status changed from Unconfirmed to New

Copying /etc/sysconfig/network-scripts/ifcfg-Auto_Ethernet from my Fedora 18 image into the SoaS 8 image restored networking.

comment:2 Changed 6 years ago by dnarvaez

  • Component changed from untriaged to sugar
  • Owner set to erikos

Temptatively assigning to sugar.

comment:3 Changed 6 years ago by dnarvaez

  • Component changed from Sugar to Sugar on a Stick (SoaS)
  • Owner changed from erikos to pbrobinson

comment:4 follow-up: Changed 6 years ago by pbrobinson

When you say "Sugar in a window" you mean running it in a window within a gnome session?

comment:5 in reply to: ↑ 4 ; follow-up: Changed 6 years ago by FGrose

Replying to pbrobinson:

When you say "Sugar in a window" you mean running it in a window within a gnome session?

Yes.

(Networking is also lost in SoaS 9 Avocado.)

comment:6 in reply to: ↑ 5 ; follow-up: Changed 6 years ago by pbrobinson

Replying to FGrose:

Replying to pbrobinson:

When you say "Sugar in a window" you mean running it in a window within a gnome session?

Yes.

Well the gnome-shell has control over the networking when running in a window mode and sugar is basically an application running within the gnome desktop so doesn't have complete control over the network because it's gnome who has the rights so it's not expected to work the the full extent if the shell was in control. The only thing you really get in that mode is the status that your online so that sharing/chat/buddy list works.

(Networking is also lost in SoaS 9 Avocado.)

Again, is this in the Window mode? The window mode in F19 is really dead, in fact it should have really been removed and has been removed complete in F-20. It's not meant to be a means of using it day to day but rather a means of developers quickly testing their changes.

comment:7 in reply to: ↑ 6 Changed 6 years ago by FGrose

Replying to pbrobinson:

Replying to FGrose:

(Networking is also lost in SoaS 9 Avocado.)

Again, is this in the Window mode?

No. This occurs in plain SoaS.

comment:8 follow-up: Changed 6 years ago by FGrose

  • Description modified (diff)

This problem is present in Sugar 0.100.0 in Fedora 19 (tested in Sugar Runner and sugar-build).

comment:9 in reply to: ↑ 8 ; follow-up: Changed 6 years ago by pbrobinson

Replying to FGrose:

This problem is present in Sugar 0.100.0 in Fedora 19 (tested in Sugar Runner and sugar-build).

Again when running in runner it doesn't have control over the network as it's running as an app not as a DE so it's expected. Both sugar-build and runner are designed primarily as development environments and hence aren't designed to be feature parity due to the DE they're running in having the primary control over the network

comment:10 in reply to: ↑ 9 Changed 6 years ago by FGrose

Replying to pbrobinson:

{...} aren't designed to be feature parity due to the DE they're running in having the primary control over the network

OK. With Sugar Runner we can restart networking from the DE (in Fedora 19, but not Fedora 20).

But the bug is really a problem in SoaS, where the problem continues to be present in SoaS v10, and in Fedora 20.

Is using /etc/sysconfig/network-scripts/ifcfg-Auto_Ethernet a reasonable solution?

Last edited 6 years ago by FGrose (previous) (diff)

comment:11 Changed 6 years ago by FGrose

  • Summary changed from Pressing Discard network history removes networking even after reboot in SoaS to Pressing Discard network history removes wired networking even after reboot in SoaS

With SoaS, one may use this command line to create a new, autoconnect, NetworkManager connection and re-establish wired networking:

 nmcli con add type ethernet ifname em1 con-name "Wired connection 1"

Tested in SoaS 10.

With Fedora 20 on different hardware, ifname p2p1 worked for me:

 nmcli con add type ethernet ifname p2p1
Last edited 6 years ago by FGrose (previous) (diff)

comment:12 Changed 6 years ago by FGrose

  • Component changed from Sugar on a Stick (SoaS) to Sugar
  • Owner changed from pbrobinson to dnarvaez
  • Summary changed from Pressing Discard network history removes wired networking even after reboot in SoaS to Pressing Discard network history removes wired networking even after reboot

This excessive behavior is native to sugar.

See this pull request for a proposed fix,
https://github.com/sugarlabs/sugar/pull/241

With Fedora 20 GNOME desktop, as of this date the graphical NetworkManager applet is not able to re-establish networking. The command line in comment:11 was needed.

Last edited 6 years ago by FGrose (previous) (diff)

comment:13 Changed 6 years ago by Frederick Grose

  • Resolution set to fixed
  • Status changed from new to closed

Rework wireless control panel section to respect non-wireless connections

Fixes #4410 https://bugs.sugarlabs.org/ticket/4410

The 'Discard network history' button is peculiar to Sugar, and
is destructive to all non-wireless connections, despite being in
the 'Wireless' section of the control panel.

Relabel the code variables and functions to be specific to
wireless connections.

Recode the functions to exclude non-wireless connections and
include only 802-11-wireless or 802-11-olpc-mesh types.

To minimize the chances that a manually created connection (such
as 'Sugar Ad-hoc Network 2') is falsely white-listed as one of the
Sugar internal ad hoc or olpc-mesh connections, each connection
is tested against a discrete white list and specific to the
wireless mode or connection type.

Relabel the 'Radio' box instructions and 'Discard ...' button
to avoid confusion over their state and actions.

Feature description:
https://wiki.sugarlabs.org/go/Features/Network_control_panel

Changeset: 4154c440fb327de1ce0511753a04eaf4943a5b2a

Note: See TracTickets for help on using tickets.