Opened 8 years ago

Closed 3 years ago

#4400 closed defect (fixed)

It is possible to save and restore an empty playlist from the Journal

Reported by: humitos Owned by: humitos
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Jukebox Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Steps to reproduce it:

Test Case 1

  1. Open Jukebox
  2. Close the Object Chooser
  3. Close Jukebox
  4. Resume the previous instance

Test Case 2

  1. Open Jukebox
  2. Add some tracks
  3. Remove all the tracks
  4. Resume the previous instance

Issue:

Jukebox does not show the Object Chooser.

Expected behaviour:

Show the Object Chooser because the playlist is empty.

Environment:

XO-4 13.1.0 os22

Change History (1)

comment:1 Changed 3 years ago by quozl

  • Resolution set to fixed
  • Status changed from new to closed

An empty playlist was being interpreted as an empty media file.

Fixed in https://github.com/sugarlabs/jukebox-activity/pull/17/commits/fb3ee2597379d899c6fcfb85f3c1071ac53b9332

Note: See TracTickets for help on using tickets.