Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#4390 closed defect (fixed)

'X' button from pdf tab page does not cancel the downloading progress

Reported by: humitos Owned by: humitos
Priority: Normal Milestone:
Component: Browse Version: Git as of bugdate
Severity: Unspecified Keywords: r+, olpc-test-pending
Cc: manuq Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

While I was testing #4385 I put a logging.debug to know the progress of the downloading progress. Then I realized that when I click on a PDF file, and a new tab is opened, if I click on the X from the tab label the downloading progress is not cancelled. I could see how the progress increments...

It seems that PDFTabPage.cancel_download is not being called.

Attachments (2)

test_case-4390.diff (424 bytes) - added by humitos 7 years ago.
Adds a logging.debug to see what is happening when the 'X' is pressed
0001-Cancel-PDF-download-when-X-from-TabLabel-is-clicked-.patch (2.3 KB) - added by humitos 7 years ago.

Download all attachments as: .zip

Change History (6)

Changed 7 years ago by humitos

Adds a logging.debug to see what is happening when the 'X' is pressed

comment:1 Changed 7 years ago by manuq

Couldn't reproduce in Browse from latest git. I can cancel a download with the X button in the tab, and also with the X button in the entry, and with the Cancel button in the canvas.

comment:2 Changed 7 years ago by humitos

  • Cc manuq added
  • Keywords r? added

Patch attached. Please, apply the test_case-4390.diff to test the PATCH and look at the .log file.

comment:3 Changed 7 years ago by manuq

  • Keywords r+ olpc-test-pending added; r? removed
  • Resolution set to fixed
  • Status changed from new to closed

Excellent. Now I got it, the download was still happening in the background, while the GUI progress was correctly stopped.

The approach looks right. the patch calls the view's close tab, which then calls cancel_download if it is a pdf view. Tested and pushed as 6afcd530 .

comment:4 Changed 7 years ago by dnarvaez

  • Milestone 1.0 deleted

Milestone 1.0 deleted

Note: See TracTickets for help on using tickets.