Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#4385 closed defect (fixed)

Browse: opening a PDF the second time shows bad download progress

Reported by: manuq Owned by: humitos
Priority: Unspecified by Maintainer Milestone:
Component: Browse Version: Unspecified
Severity: Unspecified Keywords: upstream, r+
Cc: manuq, godiard, humitos Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

TestCase:

  • The progress can be seen in the url entry. Cancel it at about 50%, closing the tab or clicking the X icon in the entry.
  • Click on the link again and wait.

The progress will not be displayed until it reaches 50%. That is, it will start displaying after it passes the reached percent. If the PDF was downloaded and displayed, closing and opening it again will not show any progress at all.

Expected behaviour: always show the progress.

Maybe this means that webkit can remember the downloaded bits. In that case, Browse doesn't seem to take adventage of that, because the long wait shows that it is downloading them again.

Attachments (2)

download_twice_same_file_with_webkit.py (2.0 KB) - added by humitos 8 years ago.
Test Case
0001-Download-progress-bar-SL-4385.patch (3.4 KB) - added by humitos 8 years ago.
Workaround for this WebKit+ bug

Download all attachments as: .zip

Change History (7)

Changed 8 years ago by humitos

Test Case

comment:1 Changed 8 years ago by humitos

Attached there is a Test Case for this. The idea is to download the same file twice or more times to see that the notify::progress signal is emitted when the previous value of progress is reached. However the file is not resumed, it's downloaded from scratch the second time.

This seems to be a bug on webkit. I'm asking on #webkit about this.

comment:2 Changed 8 years ago by humitos

  • Cc manuq added
  • Keywords upstream added

Changed 8 years ago by humitos

Workaround for this WebKit+ bug

comment:3 Changed 8 years ago by humitos

  • Cc godiard humitos added
  • Keywords r? added

comment:4 Changed 8 years ago by manuq

  • Keywords r+ added; r? removed
  • Resolution set to fixed
  • Status changed from new to closed

Upstream didn't answer. Pushed workaround as 5234aee5 .

comment:5 Changed 8 years ago by dnarvaez

  • Milestone 1.0 deleted

Milestone 1.0 deleted

Note: See TracTickets for help on using tickets.