Opened 8 years ago

Closed 7 years ago

#4378 closed defect (obsolete)

Physics crashes when adding rectangles with the touch screen

Reported by: carrott Owned by: garycmartin
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Physics Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: OLPC
Bug Status: Unconfirmed

Description

Sometimes physics crashes when you add a rectangle immediately after selecting the rectangle tool using the touch screen. See the log below.

If you touch the rectangle tool and then touch the canvas right next to the menu bar, about 1/3 of the time physics crashes. When physics crashes it just disappears. Repeatedly touching the rectangle tool followed by the canvas will quickly cause the crash. Using the mouse does not seem to cause a crash.

Physics 11 on build 13.1.0 for XO-4 (build 22) on XO-4 B1 with new tinted touchscreen.

** Message: pygobject_register_sinkfunc is deprecated (HippoCanvasBox)
1358140144.858504 WARNING root: KeepButton has been deprecated since Sugar 0.94 and should not be used in newly written code.
1358140144.881680 WARNING root: No gtk.AccelGroup in the top level window.
1358140144.908473 WARNING root: No gtk.AccelGroup in the top level window.
/usr/lib/python2.7/site-packages/sugar/graphics/toolbarbox.py:117: Warning: g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed
  self.props.palette.add(self.page_widget)
1358140144.978492 WARNING root: No gtk.AccelGroup in the top level window.
1358140145.002877 WARNING root: No gtk.AccelGroup in the top level window.
1358140145.018469 WARNING root: No gtk.AccelGroup in the top level window.
1358140145.038474 WARNING root: No gtk.AccelGroup in the top level window.
1358140145.078498 WARNING root: No gtk.AccelGroup in the top level window.
1358140145.101892 WARNING root: No gtk.AccelGroup in the top level window.
1358140145.118490 WARNING root: No gtk.AccelGroup in the top level window.
1358140145.147814 WARNING root: No gtk.AccelGroup in the top level window.
1358140145.168495 WARNING root: No gtk.AccelGroup in the top level window.
1358140145.188683 WARNING root: No gtk.AccelGroup in the top level window.
1358140145.208493 WARNING root: No gtk.AccelGroup in the top level window.
1358140145.248496 WARNING root: No gtk.AccelGroup in the top level window.
/usr/lib/python2.7/site-packages/sugar/graphics/window.py:194: Warning: g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed
  self.__vbox.pack_start(toolbar_box, False)
1358140145.263873 WARNING root: No gtk.AccelGroup in the top level window.
/usr/lib/python2.7/site-packages/sugar/graphics/toolbarbox.py:45: Warning: g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed
  self.parent.owner.pack_start(self.page_widget)
1358140145.270414 WARNING root: No gtk.AccelGroup in the top level window.
1358140171.211955 ERROR olpcgames.canvas: Uncaught top-level exception: Traceback (most recent call last):
  File "/home/olpc/Activities/Physics.activity/olpcgames/canvas.py", line 122, in _start
    fn()
  File "/home/olpc/Activities/Physics.activity/physics.py", line 133, in main
    game.run()
  File "/home/olpc/Activities/Physics.activity/physics.py", line 86, in run
    self.currentTool.handleEvents(event)
  File "/home/olpc/Activities/Physics.activity/tools.py", line 74, in handleEvents
    return self.handleToolEvent(event)
  File "/home/olpc/Activities/Physics.activity/tools.py", line 153, in handleToolEvent
    self.game.world.add.rect(self.rect.center,
AttributeError: 'NoneType' object has no attribute 'center'

Exception in thread Thread-1:
Traceback (most recent call last):
  File "/usr/lib/python2.7/threading.py", line 551, in __bootstrap_inner
    self.run()
  File "/usr/lib/python2.7/threading.py", line 504, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/home/olpc/Activities/Physics.activity/olpcgames/canvas.py", line 122, in _start
    fn()
  File "/home/olpc/Activities/Physics.activity/physics.py", line 133, in main
    game.run()
  File "/home/olpc/Activities/Physics.activity/physics.py", line 86, in run
    self.currentTool.handleEvents(event)
  File "/home/olpc/Activities/Physics.activity/tools.py", line 74, in handleEvents
    return self.handleToolEvent(event)
  File "/home/olpc/Activities/Physics.activity/tools.py", line 153, in handleToolEvent
    self.game.world.add.rect(self.rect.center,
AttributeError: 'NoneType' object has no attribute 'center'

* Pygame selected as renderer
Exited with status 0, pid 923 data (None, <open file '<fdopen>', mode 'w' at 0x10d9cd8>, '649fce4f2896771f524b28e2d53ac2cc2ed046d3')

Change History (1)

comment:1 Changed 7 years ago by walter

  • Resolution set to obsolete
  • Status changed from new to closed

I cannot reproduce with Physics v13. Please reopen if problem reoccurs.

Note: See TracTickets for help on using tickets.